[CLOSED] NetworkManager 'dead' after update 19-03-2018

Post Reply
User avatar
Posts: 40
Joined: Wed Dec 20, 2017 3:29 pm

Hi all
Just installed/upgraded ArchMerge 6.5.1 and after reboot NetworkManager not starting up
updater picked up this version of '' networkmanager 1.10.6-2 ''
any way it was full functional V.M on vBox hosted w10, before update
BTW i have also ArchMerge 6.4.1 on same host (same vBox) and this one survived this upgrade for now.
(Both are XFCE desktops)

Code: Select all

[foo@vb-asus-n750 ~]$ uname -a
Linux vb-asus-n750 4.15.10-1-ARCH #1 SMP PREEMPT Thu Mar 15 12:24:34 UTC 2018 x86_64 GNU/Linux
[foo@vb-asus-n750 ~]$ 
try to run manually Net.Man.. i get this error

Code: Select all

[foo@vb-asus-n750 ~]$ sudo NetworkManager 
NetworkManager: error while loading shared libraries: libpsl.so.6: cannot open shared object file: No such file or directory
from google found some tips, but didn't solve this problem yet

Code: Select all

[foo@vb-asus-n750 ~]$ sudo ln -sf /usr/lib/libpsl.so.6 /usr/lib/libpsl.so.5
[sudo] password for foo: 
also tried to re-install from

Code: Select all

but still no go
User avatar
Posts: 15
Joined: Wed Jan 10, 2018 10:59 am

I searched for your problem and in the last week, others has the same issue. On Manjaro forum I found a post where a guy solved his problem, he reinstalled libpsl and networkmanager packages with pacman -U
User avatar
Posts: 40
Joined: Wed Dec 20, 2017 3:29 pm

Thanks @TheWanderer for stepping in!

As it is only a Virtual Machine, there is nothing critical or something to be worried about.
So i just left this machine into this state for now (as long as have disk space on host)

(LOL May be someday i become smarter LOL and can fix it with some linux magic ;) ''chroot'' or something
not sure currently but leave it for future task :) Well, for ''sake of science'' it would be nice
to get to the root of the problem :) but ok will see later

BTW last thing i noticed on that broken VM, that even pacman was also 'gone'
all pacman commands even ''man pacman '' give the same 'error on shared lib's ..''

i cannot suspect eny operations what may cause that situation,
anyway if only that case
when i run these updates, as You know - for some updates there will stop in 'password' prompt
and unfortunately i got sidetraced meanwhile, .. and my host machine was on battery power.. and ofcourse it hibernated,
but when i got back, waked it up, entered pw and all update process continued as nothing happend, no errors ..
.. but never know ?

Also i have not installed any 'un-usual' software, exept NEMO file manager, but this never caused eny errors
on other machines now and earlier with any updates what-so-ever.

Anyway i have fired up new VM from ArchMerge 6.5.1 iso, and run all latest updates (21-03-2018)
all works fine, also updated/upgraded both 'real machines' without any issues.
/(just a note, these real machines are ArchMerge6-4-1 base, but as there is no 'Long live' for ArchMerge anyway, i am waiting for
ArcoLinux release, and do clean install to both)

Many Thanks for support!
Post Reply

Return to “Network”