[SOLVED] Slow Application Startup After System Update

Post Reply
BonfireAtNight
Crewman
Posts: 3
Joined: Sun May 21, 2023 9:16 am

Hey there,

First information on my system:
https://linux-hardware.org/?probe=2df0364d3c

Since the last `pacman -Syu` some of my applications take very long to open. I first noticed the issue with Firefox. Before it took about two or three seconds for it to be ready, now it takes way more than half a minute. The same is true for other applications, including Thunar, Gnome Archive Manager, and Evince. It's not general, though. Zathura, for instance, is as snappy as ever.

Helpful people on Reddit pointed to `xdg-desktop-portal-gnome` as causing similar behavior on many systems. However, I don't have that particular package. I have `xdg-desktop-menu` and `xdg-desktop-icon`, so could this be the problem? And could I safely remove them without breaking things?

I had a look at the other threads and wasn't sure whether to put my question here (it has to do with Pacman, but isn't the installation of software in a narrower sense). Sorry if my first contribution went to the wrong place already.

Any insight and suggestion would be greatly appreciated!
User avatar
erikdubois
Captain
Posts: 5568
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Lets wait for the Arch Linux people to migrate.

Seems to be finished.

https://archlinux.org/news/git-migration-completed/

Now we update and test again.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.
BonfireAtNight
Crewman
Posts: 3
Joined: Sun May 21, 2023 9:16 am

Thanks for your reply! I've updated my system after the migration. So far the issue remains, though.
User avatar
erikdubois
Captain
Posts: 5568
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

to be continued then
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.
BonfireAtNight
Crewman
Posts: 3
Joined: Sun May 21, 2023 9:16 am

As others have suggested, removing `xdg-desktop-portal-gnome` solved the issue. To be honest, I've read about this even before coming here but I thought I didn't have it because it wasn't part of my path. It probably isn't even an executable? In any way, I removed the package with pacman and now everything runs as smooth as it did before the update.

This thread can be closed. :)
Post Reply

Return to “Installation of Software (pacman, AUR, ...)”