[INFO] Post covering NVidia, Wayland, Steam, Pipewire, LMMS, DACs

Post Reply
User avatar
Posts: 8
Joined: Wed Mar 16, 2022 10:12 am

Hello everybody,

I allow to post some information what I am using my Laptop with Arco Linux.
As always, this is in my case, but hope other find it useful.

I am using
1. a XMG Fusion 15 Laptop with an NVidia GTX 1660Ti mobile, a second 28" screen with 240Hz Refresh Rate. The built in screen runs 144Hz. both 1920x1080.
2. Gnome 43.3 Wayland as DE and Mutter as WM.
3. Sound API: ALSA v: k6.1.12-arch1-1 running: yes, Sound Server-1: PipeWire v: 0.3.66 running: yes

Here are the reasons for that setup.
1. I had a high CPU usage running XORG running different DEs. So I switched to Wayland (Gnome offered it out of the box).
The result was a much lower CPU Usage and cooler (52°-53° on all 6 Cores) and quieter (2x fans 2700-2900 rpm) Computer. Initially using Wayland I had problems running all games in Steam, BUT this is also being resolved now. I assume (!) it was fixed by Steam, not sure.
See my post when searching for "XORG high CPU"

2. Pipewire and DAC. I started getting for my Desktop DAC - AMP - Preamp equipement (Burson Conductor 160D and Fostex HP-A4BL). Initially using USB from the laptop to the DACs, but switched to Optical (Laptop 3.5mm out to RCA converting to Optical).
The issue was that the Fostex DAC was not giving any sound out, even it seems the test are successful, but quiet. The Burson Conductor worked. I check on my 2nd Arco Linux Laptop, same problem. I worked on that issue for two days, when I remember something about pipewire instead of ALSA.
checking the laptop with inxi -Fz I saw that I had two Sound Servers running: ALSA and Pipewire. I unininstalled ALSA following the Youtube Video "ArcoLinux : 2514 How to switch from pulseaudio to pipewire and back - how to make a script" from Erik Dubois (thanks).
I did some minor changes, but follow the script settings and end result is that the both DACs working fine with using Pipewire.

3. USB Keystation61 from M-Audio. I am bringing that unit back and it works too with my setup without having to configure anything.

It is not the usual every day things I am having with my Arco Linux setup, but it is working and I wanted to share this information.
Today I am doing nothing and I am ahead in time :mrgreen:
Post Reply

Return to “Multimedia and Games”