[SOLVED] How to make Pipewire automatically assign every new output to my USB headset?

First check the forums - Do not know where to put it then put it here
Post Reply
rempas
Crewman
Posts: 8
Joined: Sun Feb 20, 2022 2:22 pm

Hello! I have replaced pulseaudio with pipewire some days ago and everything went great! However, yesterday I bought a new headset and I was not able to hear any sound when I connected it. For the record, my new headset is a USB headset and the old one (one I was using until now) is a 3.5MM jack one. So, the problem is that, while pipewire will automatically assign any sound output (like the sound played in YT videos on Librewolf) to my 3.5MM jack headset, it will not do that automatically for my USB one and I'll have to do it manually. Even if only my USB headset is connected, it will still not automatically do that for me. So I guess that it isn't about which one is the "primary" one. I did tried to find configuration settings on "qpwgraph", "carla" and "qjacktl" and had no luck. Any ideas?

EDIT:
After countless of hours searching yesterday and today, I was finally able to find the solution in the Arch Linux Wiki page about Pipewire in the section 5.1.2!
Post Reply

Return to “General Questions”