[SOLVED] First iso build install stuck at boot

Post Reply
sugarcrisp
Crewman
Posts: 42
Joined: Mon Oct 19, 2020 3:47 pm

[SOLVED] First iso build install stuck at boot

Post by sugarcrisp »

I've just completed my first ever iso build. Everything seemed to go well. However, when I try to install it in Virtualbox, it gets stuck in a loop at the boot menu. I don't see any options to edit the boot, so I can't check to see if I can notice anything wrong. Any suggestions on how to correct the boot?
Last edited by sugarcrisp on Mon Dec 27, 2021 3:53 am, edited 1 time in total.

User avatar
erikdubois
Captain
Posts: 5091
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] First iso build install stuck at boot

Post by erikdubois »

Well do not change anything and build the iso as we have done for the last 4 years.

If that works you can start changing elements.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

User avatar
erikdubois
Captain
Posts: 5091
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] First iso build install stuck at boot

Post by erikdubois »

Your virtual box settings have to be correct

Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

sugarcrisp
Crewman
Posts: 42
Joined: Mon Oct 19, 2020 3:47 pm

Re: [OPEN] First iso build install stuck at boot

Post by sugarcrisp »

Hey Erik. I will test that and see how things go

User avatar
erikdubois
Captain
Posts: 5091
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] First iso build install stuck at boot

Post by erikdubois »

You have to look up the very first error.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

sugarcrisp
Crewman
Posts: 42
Joined: Mon Oct 19, 2020 3:47 pm

Re: [OPEN] First iso build install stuck at boot

Post by sugarcrisp »

As expected, when I build the original, it works just as expected. When I build mine, I get the following error (don't know if I received any errors with the original)

Code: Select all

Failed to open file "/sys/devices/system/cpu/microcode/reload": Read-only file system
error: command failed to execute correctly
I will slowly add a few of my changes and retest.

User avatar
erikdubois
Captain
Posts: 5091
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] First iso build install stuck at boot

Post by erikdubois »

that is ok

no error

do you have an iso as end-result

that is all that counts
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

sugarcrisp
Crewman
Posts: 42
Joined: Mon Oct 19, 2020 3:47 pm

Re: [OPEN] First iso build install stuck at boot

Post by sugarcrisp »

Looks like I found the issue. When I made changes to the file list, I put # in front of "amd-ucode" under Packages Available. After removing it and doing a new iso build, I was able to install to Virtualbox. Now I can continue with my testing. Thanks Erik.

User avatar
erikdubois
Captain
Posts: 5091
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [SOLVED] First iso build install stuck at boot

Post by erikdubois »

great

meld meld meld ;-)
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

Post Reply

Return to “BYOI ArcoLinuxB i3”