[INFO] nVidia Kepler & Linux

Post Reply
DarkXero
recruit crewman
Posts: 2
Joined: Thu Mar 11, 2021 1:47 pm

[INFO] nVidia Kepler & Linux

Post by DarkXero »

# Hey Linuxers,


Dark day for all Kepler Series nVidia card owners out there. Am sorry to announce that nVidia has gone and done it again, and has removed support for all Kepler Series cards from their latest 495xx drivers.

As a result anyone with those cards trying to install Arco will either not be able to boot ISO or get the infamous black screen after install. Why ? Well because every time we build ISO the latest drivers will be included. Nothing we can do about that.

Before it's asked, no we cannot control which driver gets included on the ISO or the installer. We are sorry on behalf of nVidia. They deserve the middle finger Linus Torvalds gave them.

Look below for a potential solution...

# A way out ?

Yes there are ways out, which is great. Still it's better than not being able to use Arco right peeps ? I mean we on Linux coz of the freedom it provides. A few commands to get up and running won't push us away I hope hehe..

### Solution one :

From the boot menu select either the first or last option in the USB boot menu whichever works for you. And in the installer in the "Drivers" section do NOT select any GPU drivers at all ! Again select no GPU drivers otherwise black screen. All should go with no issues and you will be running on the "nouveau" drivers.

But if you really want to get GPU acceleration back you can now safely grab the nVidia drivers that do work, they are currently only on the AUR. So type the following commands in terminal to install them and get back to normalcy.

Code: Select all

sudo pacman -R xf86-video-nouveau

Code: Select all

paru -S nvidia-470xx-dkms nvidia-470xx-settings nvidia-470xx-utils lib32-nvidia-470xx-utils lib32-opencl-nvidia-470xx opencl-nvidia-470xx
Now reboot and benefit :D

### Solution Two :

What you need to do is the following if you are stuck on black screen, immediately after install, or after an update, access the **TTY** by hitting the ctrl+alt+Fkey enter you login details then type the following command to downgrade driver to Legacy one ->

Code: Select all

sudo downgrade nvidia nvidia-settings nvidia-utils
if you have DKMS drivers then type the following

Code: Select all

sudo downgrade nvidia nvidia-dkms nvidia-settings nvidia-utils
then select the legacy driver versioned as `470.86`.

Once all that is done reboot system and all should be back to normal. Kindly refer to official post on nVidia's forums for more info... Again sorry guys n gals :(

Post Reply

Return to “Tips and Tricks”