[SOLVED] Budgie settings causes crash

Post Reply
User avatar
Kepos
Crewman
Posts: 34
Joined: Tue Aug 20, 2019 7:26 pm
Location: Europe

[SOLVED] Budgie settings causes crash

Post by Kepos »

Hi,

after latest updates, starting Budgie settings only shows the icon in Plank, but the app never opens.
When I click on the icon, screen calls emergancy shut-up and asks for re-login.

Any idea?

Thx.

***(corrected wrong phrase setup with settings)***
Last edited by Kepos on Wed Apr 14, 2021 9:56 am, edited 4 times in total.
OS: ArcoLinux+Manjaro+Solus OS | Resolution: 1920x1080, 1366x768 | DE: Budgie | CPU: AMD FX-8350 (8) @ 4.000GHz | GPU: AMD ATI Radeon RX 470/480/570/ | Memory: 4283MiB / 7854MiB (54%) | GPU Driver: amdgpu

User avatar
erikdubois
Captain
Posts: 4025
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] Budgie setup causes crash

Post by erikdubois »

I have updated by ArcoLinuxB Budgie ssd.
Rebooted
Installed plank

Code: Select all

sudo pacman -S plank
and started it from the terminal

Code: Select all

plank &
all is well here.

do you get a messsage in the terminal?
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

User avatar
Kepos
Crewman
Posts: 34
Joined: Tue Aug 20, 2019 7:26 pm
Location: Europe

Re: [OPEN] Budgie setup causes crash

Post by Kepos »

Hi Erik, thank you for the fast response.

Sorry, but it isn't Plank that causes the issue, it is the Budgie settings which isn't starting. I only mentioned Plank because I can watch the icon there and when I click on that icon the issue happens. Sorry, if my explanation wasn't exact enough.

And no, I do not get any warning, except I do see a grey screen with a funny computer face and the (localized) notice that 'something unforseeable has happened, the system crashed and I should log-out and re-log-in'.

I tried to fetch a screenshot, but it seems the whole system crashed with that issue.
Besides, I do not know the terminal command to start Budgie settings to get any response.


***
Other issue with latest update: my usb-ports no longer work also. I cross-checked with other distributions which proofed to work, so it is no hardware issue. I do not know if that has something to do with the above mentioned issue, but probably there are missing files or entries.
OS: ArcoLinux+Manjaro+Solus OS | Resolution: 1920x1080, 1366x768 | DE: Budgie | CPU: AMD FX-8350 (8) @ 4.000GHz | GPU: AMD ATI Radeon RX 470/480/570/ | Memory: 4283MiB / 7854MiB (54%) | GPU Driver: amdgpu

User avatar
erikdubois
Captain
Posts: 4025
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] Budgie setup causes crash

Post by erikdubois »

Might have to do with the new Gnome 4.0 that was released.

Budgie is not a stand-alone desktop - it needs Gnome to support it.

That said - it did work here. I did al my updates...

We will have to think harder...
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

User avatar
erikdubois
Captain
Posts: 4025
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] Budgie setup causes crash

Post by erikdubois »

I have booted up the ssd.

Started budgie-settings.

It is confirmed.

I too get the grey window with a sad smiley - something went wrong - can not recover and need to logout

Wait for the budgie guys to fix it. (so not Arch Linux)

It will need a fix.

If you want to know if the issue is already known to Arch Linux then you check here : https://bugs.archlinux.org/

If not you can make an account and report there if you want.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

User avatar
Kepos
Crewman
Posts: 34
Joined: Tue Aug 20, 2019 7:26 pm
Location: Europe

Re: [OPEN] Budgie setup causes crash

Post by Kepos »

Great job and thank you very much for looking that deep into it @Erik.

So I'll wait until the next Budgie/Gnome updates for another check.
OS: ArcoLinux+Manjaro+Solus OS | Resolution: 1920x1080, 1366x768 | DE: Budgie | CPU: AMD FX-8350 (8) @ 4.000GHz | GPU: AMD ATI Radeon RX 470/480/570/ | Memory: 4283MiB / 7854MiB (54%) | GPU Driver: amdgpu

User avatar
Kepos
Crewman
Posts: 34
Joined: Tue Aug 20, 2019 7:26 pm
Location: Europe

Re: [SOLVED] Budgie settings causes crash

Post by Kepos »

With todays updates the issue is solved.
Thank you for the support!
OS: ArcoLinux+Manjaro+Solus OS | Resolution: 1920x1080, 1366x768 | DE: Budgie | CPU: AMD FX-8350 (8) @ 4.000GHz | GPU: AMD ATI Radeon RX 470/480/570/ | Memory: 4283MiB / 7854MiB (54%) | GPU Driver: amdgpu

User avatar
erikdubois
Captain
Posts: 4025
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [SOLVED] Budgie settings causes crash

Post by erikdubois »

I takes 2-3 days and then Arch has fixed it.

That is my experience over the last 5.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

Post Reply

Return to “BYOI ArcoLinuxB Budgie”