ArcoLinux -D -B 18.12 has been released - 20 iso's

[OPEN] Can't enable indicators in i3blocks

i3 is a tiling window manager designed for X11, inspired by wmii, and written in C.
Post Reply
tiny_angel_in_a_jar
Crewman
Posts: 6
Joined: Sun Sep 23, 2018 8:04 pm
Bulgaria
[OPEN] Can't enable indicators in i3blocks

Post by tiny_angel_in_a_jar » Sun Oct 07, 2018 7:11 pm

Hello,
I'm trying to enable the battery indicator and the WiFi monitor in i3blocks.
Not sure If I'm doing things right, but removing the "#" before the following lines in i3blocks.conf would be enough to make it work:

Code: Select all

[wifi]
instance=wlp3s0
interval=10
separator=false

Code: Select all

[battery]
label=⚡
instance=1
interval=30
And then just $mod+Shift+r. That doesn't work for these two indicators in particular - I tried and it worked for all the stuff I don't want :)
I've installed acpi and it returns correct info, so as upower -d.
There should be something I miss and hope you guys can help me :idea:

User avatar
erikdubois
Captain
Posts: 1428
Joined: Tue Nov 07, 2017 2:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Can't enable indicators in i3blocks

Post by erikdubois » Sun Oct 07, 2018 7:34 pm

I am going to say a crazy thing.
Try it.

Re-order your modules.

Put the ones you want to see in on other place.

And try again.

This is where you need to get the milk.

https://github.com/vivien/i3blocks

https://vivien.github.io/i3blocks/

The development continues and things may have changed in the meantime.


and probably the best link is this one

https://github.com/vivien/i3blocks-contrib

Wifi was updated 2 months ago

https://github.com/vivien/i3blocks-cont ... aster/wifi
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
and only then use the power of our moderators.

User avatar
erikdubois
Captain
Posts: 1428
Joined: Tue Nov 07, 2017 2:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Can't enable indicators in i3blocks

Post by erikdubois » Sat Oct 27, 2018 9:30 am

Did you solve your issue?
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
and only then use the power of our moderators.


Post Reply

Return to “i3-wm”