ArcoLinux -D -B 18.10 are online

[OPEN] touchpad settings on i3 wm

i3 is a tiling window manager designed for X11, inspired by wmii, and written in C.
Post Reply
User avatar
ramo22
Crewman
Posts: 28
Joined: Mon Apr 30, 2018 7:04 pm
Egypt
[OPEN] touchpad settings on i3 wm

Post by ramo22 » Sun Jul 08, 2018 1:16 am

how to active tap to click on i3
and reverse scrolling
RAMO KING

User avatar
erikdubois
Captain
Posts: 1247
Joined: Tue Nov 07, 2017 2:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] touchpad settings on i3 wm

Post by erikdubois » Mon Jul 09, 2018 4:59 am

We always need to know on what system you are working and what version. An inxi -b helps us.

https://arcolinux.com/category/arcolinux/help/

This link will help us help you.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
and only then use the power of our moderators.

User avatar
ramo22
Crewman
Posts: 28
Joined: Mon Apr 30, 2018 7:04 pm
Egypt
Re: [OPEN] touchpad settings on i3 wm

Post by ramo22 » Mon Jul 09, 2018 4:30 pm

System:
Host: HP-LAP Kernel: 4.17.4-1-ARCH x86_64 bits: 64 Desktop: Xfce 4.12.4
Distro: ArcoLinux v6.8.2
Machine:
Type: Laptop System: Hewlett-Packard product: HP Pavilion 15 Notebook PC
v: 0992110000004100000600080 serial: <root required>
Mobo: Hewlett-Packard model: 2166 v: 29.42 serial: <root required> UEFI: Insyde
v: F.71 date: 03/13/2017
Battery:
ID-1: BAT0 charge: 24.2 Wh condition: 24.2/24.2 Wh (100%)
CPU:
Dual Core: Intel Core i7-4500U type: MT MCP speed: 2427 MHz min/max: 800/3000 MHz
Graphics:
Card-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
Card-2: NVIDIA GK208M [GeForce GT 740M] driver: N/A
Display: x11 server: X.Org 1.20.0 driver: modesetting unloaded: fbdev,intel,vesa
resolution: 1366x768~60Hz, 1280x1024~60Hz
OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.1.3
Network:
Card-1: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee
Card-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
Drives:
HDD Total Size: 1.03 TiB used: 763.74 GiB (72.7%)
Info:
Processes: 227 Uptime: 2h 34m Memory: 7.72 GiB used: 2.47 GiB (32.0%) Shell: zsh
inxi: 3.0.16
RAMO KING

User avatar
erikdubois
Captain
Posts: 1247
Joined: Tue Nov 07, 2017 2:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] touchpad settings on i3 wm

Post by erikdubois » Mon Jul 09, 2018 6:25 pm

Did you check these already?

https://arcolinux.com/how-to-set-double ... -touchpad/


This is the more general information

https://wiki.archlinux.org/index.php/Libinput
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
and only then use the power of our moderators.

User avatar
javierar
Crewman
Posts: 5
Joined: Sun Nov 12, 2017 5:02 am
Mexico
Re: [OPEN] touchpad settings on i3 wm

Post by javierar » Wed Aug 08, 2018 8:49 pm

Hello. I am trying I3 and had the same issue. This is how I solved it:
Check out the xinput command. xinput list will give you a list of input devices; find the ID of the one which looks like a touchpad. Then do xinput list-props <device id>, which should tell you what properties you can change for the input device. You should find one called something like Tapping Enabled and a number in parens after it (in my case, it's libinput Tapping Enabled (276). Finally, run xinput set-prop <device id> <property id> 1, and tapping should work. Source: reddit
To make this permanent, you need an extra step:
You can change the default value in your libinput config file located at

/usr/share/X11/xorg.conf.d/40-libinput.conf

(mine is actually 90-libinput.conf. anyways, something like this.)

Just add

Option "Tapping" "True"

For me, the complete entry is:

Section "InputClass"
Identifier "libinput touchpad catchall"
MatchIsTouchpad "on"
MatchDevicePath "/dev/input/event*"
Driver "libinput"
Option "Tapping" "True"
EndSection

See more at:

https://wiki.archlinux.org/index.php/Libinput
https://www.mankier.com/4/libinput
Source: askubuntu
Hmmm. Maybe that last step is all you need. You should try that.
Mastodon/GNU Social: linuxrocks.online/@javier


Post Reply

Return to “i3-wm”