[CLOSED] Probleme beim update

Post Reply
tombrake
Crewman
Posts: 4
Joined: Mon Aug 24, 2020 12:32 am

[CLOSED] Probleme beim update

Post by tombrake »

Hallo,
ich habe ein Problem bei einem Update nach der Eingabe von "sudo pacman -Syu"
es erscheint die Fehlermeldung:
Paket (3) Alte Version Neue Version Netto-Veränderung Größe des Downloads

community/pdfjs 2.8.335-1 2.9.359-1 0,16 MiB 2,85 MiB
community/perl-json 2.97001-2 4.03-1 0,02 MiB 0,08 MiB
community/youtube-dl 2021.05.16-1 2021.06.06-1 0,00 MiB 2,29 MiB

Gesamtgröße des Downloads: 5,22 MiB
Gesamtgröße der installierten Pakete: 25,10 MiB
Größendifferenz der Aktualisierung: 0,18 MiB

:: Installation fortsetzen? [J/n] j
:: Pakete werden empfangen …
pdfjs-2.9.359-1-any 2,9 MiB 4,94 MiB/s 00:01 [#####################################################] 100%
perl-json-4.03-1-any 77,8 KiB 2,53 MiB/s 00:00 [#####################################################] 100%
youtube-dl-2021.06.06-1-any 2,3 MiB 6,93 MiB/s 00:00 [#####################################################] 100%
Gesamt (3/3) 5,2 MiB 5,30 MiB/s 00:01 [#####################################################] 100%
(3/3) Schlüssel im Schlüsselbund werden geprüft [#####################################################] 100%
(3/3) Paket-Integrität wird überprüft [#####################################################] 100%
Fehler: pdfjs: signature from "Morten Linderud <morten@linderud.pw>" is marginal trust
:: Datei /var/cache/pacman/pkg/pdfjs-2.9.359-1-any.pkg.tar.zst ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: perl-json: signature from "Sergej Pupykin <arch@sergej.pp.ru>" is marginal trust
:: Datei /var/cache/pacman/pkg/perl-json-4.03-1-any.pkg.tar.zst ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: youtube-dl: signature from "Jaroslav Lichtblau <svetlemodry@archlinux.org>" is marginal trust
:: Datei /var/cache/pacman/pkg/youtube-dl-2021.06.06-1-any.pkg.tar.zst ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: Der Vorgang konnte nicht durchgeführt werden (Ungültiges oder beschädigtes Paket (PGP-Signatur))
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Was ist das für ein Problem, was kann ich machen?

Danke und Gruß

tom

Online
User avatar
erikdubois
Captain
Posts: 4131
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] Probleme beim update

Post by erikdubois »

Code: Select all

sudo pacman -Scc
sudo pacman -S archlinux-keyring
then update again with

Code: Select all

update
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

tombrake
Crewman
Posts: 4
Joined: Mon Aug 24, 2020 12:32 am

Re: [OPEN] Probleme beim update

Post by tombrake »

erikdubois wrote:
Sun Jun 06, 2021 6:25 pm

Code: Select all

sudo pacman -Scc
sudo pacman -S archlinux-keyring
then update again with

Code: Select all

update
Hallo Eric,
alles so durchgeführt, leider besteht das Problem weiterhin.
Keine Veränderung.
Hast du noch einen Tipp?
Gruß tom

Online
User avatar
erikdubois
Captain
Posts: 4131
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] Probleme beim update

Post by erikdubois »

Remove the package that is causing it

or

import the key of the developer
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

tombrake
Crewman
Posts: 4
Joined: Mon Aug 24, 2020 12:32 am

Re: [OPEN] Probleme beim update

Post by tombrake »

Leider konnte ich die fehlerhaften Pakete nicht deinstallieren, zuviele Abhängigkeiten bestanden
Außerdem wurde die Liste der fehlerhaften Pakete immer länger.
Ich habe mich dann entschlossen, das System neu zu installieren.
Irgendetwas muss ich wohl nicht richtig gemacht haben.
Vielen Dank für die Unterstützung. Lg tom

Online
User avatar
erikdubois
Captain
Posts: 4131
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] Probleme beim update

Post by erikdubois »

remember for next time

sudo pacman -Rdd is a trick to remove something regardless of the dependencies

we use it here with success

it depends what you are doing in each case ofcourse

analyze and take a course of action - re-install is the last option

Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

Post Reply

Return to “Installation of Software (pacman, AUR, ...)”