ArcoLinux -D -B 19.5 iso's have been released

[SOLVED] No Wireless Connection After Fresh Install

First check the forums - Do not know where to put it then put it here
Post Reply
rubi654
recruit crewman
Posts: 2
Joined: Thu May 16, 2019 10:19 pm
Israel
[SOLVED] No Wireless Connection After Fresh Install

Post by rubi654 » Thu May 16, 2019 10:24 pm

Hi,

Firstly, I hope this is the correct place to post this, if not please move.

Although I have used Linux for some time this was my first ever Arch based install and I have to say it went smoothly and I am impressed with what I have seen so far.

On to a minor issue; after installing and rebooting I was unable to connect to wireless networks. The only options were VPN or a wired connection.

I was going to leave it and research at a later stage then shutdown the computer to do other things. When I restarted the network connections showed available wireless networks and I could successfully connect to my router.

Has this happened before to others?

Thanks!

User avatar
erikdubois
Captain
Posts: 2153
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] No Wireless Connection After Fresh Install

Post by erikdubois » Fri May 17, 2019 6:26 am

During live session it is possible that you do not see the wireless networks.

After rebooting the wireless will kick in.

My macbook does this here.

I understood it did not at first...

Might be interesting to see if there are elements blacklisted.

/usr/lib/modprobe.d
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

rubi654
recruit crewman
Posts: 2
Joined: Thu May 16, 2019 10:19 pm
Israel
Re: [OPEN] No Wireless Connection After Fresh Install

Post by rubi654 » Fri May 17, 2019 10:01 am

Hi,

Yes, I also thought perhaps it would only be during the live session.

The only file of relevance in modprobe.d was for the wireless card, a Broadcom.

Contents of the file broadcom-wl.conf:

Code: Select all

blacklist b43
blacklist b43legacy
blacklist ssb
blacklist bcm43xx
blacklist brcm80211
blacklist brcmfmac
blacklist brcmsmac
blacklist bcma
As I said after the first reboot could not connect but after the second restart all worked automatically.

Thanks.

User avatar
erikdubois
Captain
Posts: 2153
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] No Wireless Connection After Fresh Install

Post by erikdubois » Fri May 17, 2019 10:24 pm

ok
let us mark as solved for now.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.


Post Reply

Return to “General Questions”