ArcoLinux -D 18.11 has been released

[SOLVED] How to update pamac-aur and phonon-qt4 on 28/08/2018

Beginners' subforum for general ArcoLinux issues. Please consult the excellent Arch wiki and web before posting.
Post Reply
User avatar
MicroCode
Crewman
Posts: 20
Joined: Mon Jan 08, 2018 8:32 am
Croatia
[SOLVED] How to update pamac-aur and phonon-qt4 on 28/08/2018

Post by MicroCode » Tue Aug 28, 2018 12:13 pm

Hello
maybe the problem is just me or is it for everything?

I tried a bit before updating "pksyua"
I see it does not pass a pamac-aur new version? package: pamac-aur 6.9.0-1

If we have this problem: ?? can instruct how to fix it

NOTICE: I uninstalled the old package and tried new and will not?
  - I tried directly with the script and it will not work? install-pamac-aur-v1.sh
ArcoLinuxB v6.9.2 plasma fresh install
###################################################################

Code: Select all

[db@old-pc AUR]$ ./install-pamac-aur-v1.sh 
Installing with yaourt

==> Downloading pamac-aur PKGBUILD from AUR...
x .SRCINFO
x .gitignore
x PKGBUILD
x pamac.install
Lone_Wolf commented on 2018-06-05 22:32			 

khriss commented on 2018-06-08 13:24			 

bertof commented on 2018-08-27 07:51			 

brenosilveira1 commented on 2018-08-27 08:52			 

HunabKu commented on 2018-08-27 09:04			 

pamac-aur 6.9.0-1  (2018-08-27 07:40)
( Unsupported package: Potentially dangerous ! )
==> pamac-aur dependencies:
 - glib2>=2.42 (already installed)
 - json-glib (already installed)
 - libsoup (already installed)
 - dbus-glib (already installed)
 - polkit (already installed)
 - vte3>=0.38 (already installed)
 - gtk3>=3.22 (already installed)
 - libnotify (already installed)
 - desktop-file-utils (already installed)
 - pacman>=5.1 (already installed)
 - gnutls>=3.4 (already installed)
 - appstream-glib (already installed)
 - archlinux-appstream-data (already installed)
 - gettext (already installed) [makedepend]
 - itstool (already installed) [makedepend]
 - vala>=0.36.6 (already installed) [makedepend]
 - meson (already installed) [makedepend]
 - ninja (already installed) [makedepend]
 - git (already installed) [makedepend]


==> Continue building pamac-aur ? [Y/n]
==> -----------------------------------
==> 
==> Building and installing package
==> Making package: pamac-aur 6.9.0-1 (utorak, 28. kolovoza 2018. 13:44:19 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading pamac-6.9.0-1.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  328k  100  328k    0     0   404k      0 --:--:-- --:--:-- --:--:--  403k
==> Validating source files with sha256sums...
    pamac-6.9.0-1.tar.gz ... Passed
==> Extracting sources...
  -> Extracting pamac-6.9.0-1.tar.gz with bsdtar
==> Starting prepare()...
==> Starting build()...
The Meson build system
Version: 0.47.2
Source dir: /tmp/yaourt-tmp-db/aur-pamac-aur/src/pamac-v6.9.0
Build dir: /tmp/yaourt-tmp-db/aur-pamac-aur/src/pamac-v6.9.0/builddir
Build type: native build
Project name: pamac
Project version: undefined
Appending CFLAGS from environment: '-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt'
Appending LDFLAGS from environment: '-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now'
Appending CPPFLAGS from environment: '-D_FORTIFY_SOURCE=2'
Native C compiler: cc (gcc 8.2.0 "cc (GCC) 8.2.0")
Appending LDFLAGS from environment: '-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now'
Native Vala compiler: valac (valac 0.40.9)
Build machine cpu family: x86_64
Build machine cpu: x86_64
Found pkg-config: /usr/bin/pkg-config (1.5.3)
Native dependency glib-2.0 found: YES 2.56.2
Native dependency gobject-2.0 found: YES 2.56.2
Native dependency gio-2.0 found: YES 2.56.2
Native dependency gthread-2.0 found: YES 2.56.2
Native dependency libalpm found: YES 11.0.1
Native dependency json-glib-1.0 found: YES 1.4.2
Native dependency libsoup-2.4 found: YES 2.62.3
Native dependency polkit-gobject-1 found: YES 0.114
Native dependency libcurl found: YES 7.61.0
Native dependency libnotify found: YES 0.7.7
Native dependency appstream-glib found: YES 0.7.10
Native dependency gtk+-3.0 found: YES 3.22.30
Native dependency gdk-3.0 found: YES 3.22.30
Native dependency gdk-pixbuf-2.0 found: YES 2.36.12
Native dependency vte-2.91 found: YES 0.52.2
Library posix found: YES
Library m found: YES
Program g-ir-compiler found: NO

src/meson.build:101:0: ERROR:  Program(s) ['g-ir-compiler'] not found or not executable

A full log can be found at /tmp/yaourt-tmp-db/aur-pamac-aur/src/pamac-v6.9.0/builddir/meson-logs/meson-log.txt
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build pamac-aur.
==> Restart building pamac-aur ? [y/N]
==> ----------------------------------
==> [db@old-pc AUR]$ 
----------------------------------------------------------------------------------------------------------------------------------------------------

pksyua
ERROR and to this : phonon-qt4

Code: Select all

==> Package upgrade only (new release):
aur/phonon-qt4 4.10.1-1 1 -> 2

==> Continue upgrade ? [Y/n]
==> [V]iew package detail   [M]anually select packages
==> --------------------------------------------------
==> 
==> Downloading phonon-qt4 PKGBUILD from AUR...
x .SRCINFO
x PKGBUILD
bulletproof commented on 2018-08-25 14:41			 

iHmD commented on 2018-08-26 13:19			 

bartus commented on 2018-08-26 13:53			 

Alad commented on 2018-08-28 07:40			 

bartus commented on 2018-08-28 09:15			 

phonon-qt4 4.10.1-2  (2018-08-24 15:06)
( Unsupported package: Potentially dangerous ! )
==> phonon-qt4 dependencies:
 - extra-cmake-modules (already installed) [makedepend]
 - libpulse (already installed) [makedepend]
 - qt4 (already installed) [makedepend]


==> Continue building phonon-qt4 ? [Y/n]
==> ------------------------------------
==> 
==> Building and installing package
==> Making package: phonon-qt4 4.10.1-2 (utorak, 28. kolovoza 2018. 17:08:17 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading phonon-4.10.1.tar.xz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   356  100   356    0     0   1253      0 --:--:-- --:--:-- --:--:--  1253
100   345  100   345    0     0    546      0 --:--:-- --:--:-- --:--:--   546
100  314k  100  314k    0     0   242k      0  0:00:01  0:00:01 --:--:--  814k
  -> Downloading phonon-4.10.1.tar.xz.sig...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   360  100   360    0     0   1722      0 --:--:-- --:--:-- --:--:--  1722
100   819  100   819    0     0   1470      0 --:--:-- --:--:-- --:--:--  1470
==> Validating source files with sha256sums...
    phonon-4.10.1.tar.xz ... Passed
    phonon-4.10.1.tar.xz.sig ... Skipped
==> Verifying source file signatures with gpg...
    phonon-4.10.1.tar.xz ... FAILED (unknown public key B92A5F04EC949121)
==> ERROR: One or more PGP signatures could not be verified!
==> ERROR: Makepkg was unable to build phonon-qt4.
==> Restart building phonon-qt4 ? [y/N]
==> -----------------------------------
==> ==> ERROR: unable to update
Last edited by MicroCode on Tue Aug 28, 2018 3:16 pm, edited 1 time in total.

Mic
Crewman
Posts: 42
Joined: Sat Mar 10, 2018 4:39 pm
Location: Nantes-France
France
Re: ERROR: Makepkg was unable to build pamac-aur

Post by Mic » Tue Aug 28, 2018 1:47 pm

Hello,

Problem idem for me.
Nobody is perfect..... :lol:

User avatar
erikdubois
Captain
Posts: 1332
Joined: Tue Nov 07, 2017 2:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] ERROR: Makepkg was unable to build pamac-aur

Post by erikdubois » Tue Aug 28, 2018 5:10 pm

Always check the AUR website first

https://aur.archlinux.org/packages/pamac-aur/
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
and only then use the power of our moderators.

User avatar
erikdubois
Captain
Posts: 1332
Joined: Tue Nov 07, 2017 2:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] ERROR: Makepkg was unable to build pamac-aur

Post by erikdubois » Tue Aug 28, 2018 5:20 pm

Installing gobject-introspection gets us a bit further in the installation.

Code: Select all

sudo pacman -S gobject-introspection
But it is a pgp key that needs importing that we do not get.

phonon-qt4 requires importing of a key

CB9387521E1EE0127DA804843FDBB55084CC5D84

Then I looked on the website.

https://arcolinux.com/fix-for-one-or-mo ... -verified/

and found

Code: Select all

trizen phonon-qt4 --skipinteg
And everything is back up to date
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
and only then use the power of our moderators.

User avatar
MicroCode
Crewman
Posts: 20
Joined: Mon Jan 08, 2018 8:32 am
Croatia
Re: [SOLVED] How to update pamac-aur and phonon-qt4 on 28/08/2018

Post by MicroCode » Tue Aug 28, 2018 6:39 pm

Thanks a lot you Erik

now everything is ok and has been updated successfully :)

Mic
Crewman
Posts: 42
Joined: Sat Mar 10, 2018 4:39 pm
Location: Nantes-France
France
Re: [SOLVED] How to update pamac-aur and phonon-qt4 on 28/08/2018

Post by Mic » Wed Aug 29, 2018 3:11 am

It's ok for me. Thank you . :)
Nobody is perfect..... :lol:

User avatar
erikdubois
Captain
Posts: 1332
Joined: Tue Nov 07, 2017 2:45 pm
Location: Belgium
Contact:
Belgium
Re: [SOLVED] How to update pamac-aur and phonon-qt4 on 28/08/2018

Post by erikdubois » Wed Aug 29, 2018 6:35 am

1 day later the AUR pkgbuild was changed to include the missing package gobject-introspection

-makedepends=('gettext' 'itstool' 'vala>=0.36.6' 'meson' 'ninja' 'git')
+makedepends=('gettext' 'itstool' 'vala>=0.36.6' 'meson' 'ninja' 'git' 'gobject-introspection')

https://aur.archlinux.org/cgit/aur.git/ ... =pamac-aur

Let us all help the pkbuilders from AUR and flag their packages out of date so they get a mail to alert them.
They are not constantly checking that things are ok. Nor should they. We, the users, will do that and alert them.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
and only then use the power of our moderators.


Post Reply

Return to “General”