[OPEN] SDDM not launching

First check the forums - Do not know where to put it then put it here
sugarcrisp
Crewman
Posts: 24
Joined: Mon Oct 19, 2020 3:47 pm

Re: [OPEN] SDDM not launching

Post by sugarcrisp »

I did remove all of the arcolinux-lightdm packages and only have the standard ones installed. I'm currently running Arcolinux on bare metal. I only use Virtualbox (6.1.18) to run Windows and for testing Linux.

User avatar
erikdubois
Captain
Posts: 3875
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] SDDM not launching

Post by erikdubois »

So you are running on metal.

And SDDM just says - no can do....

You are the first reporting that.

Stick to lightdm I would say.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

User avatar
erikdubois
Captain
Posts: 3875
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] SDDM not launching

Post by erikdubois »

Do you know what?

Give me a new probe link now.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

sugarcrisp
Crewman
Posts: 24
Joined: Mon Oct 19, 2020 3:47 pm

Re: [OPEN] SDDM not launching

Post by sugarcrisp »

https://linux-hardware.org/?probe=87c36a9322

One thing I just remembered. I'm currently on Kernel 5.11.arch2-1. This turned out to be a fix for a bluetooth issue I was having.

User avatar
erikdubois
Captain
Posts: 3875
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] SDDM not launching

Post by erikdubois »

I checked the package list.

All xf86 are gone but one.

Can you remove the last one?

xf86-video-vmware 13.3.0-2

remove any dependencies as well - there was one I believe.

If you are on metal you do not need it
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

sugarcrisp
Crewman
Posts: 24
Joined: Mon Oct 19, 2020 3:47 pm

Re: [OPEN] SDDM not launching

Post by sugarcrisp »

I removed xf86-video-vmware and the dependencies. Ran tosddm and rebooted. No change. However, I switched to tty and tried to restart sddm and I noticed a line that didn't look correct.

Code: Select all

Starting: "usr/share/sddm/scripts/wayland-session startxfce4"
loginctl

Code: Select all

SESSION  UID USER  SEAT  TTY
      2 1000 brett seat0    

1 sessions listed.
loginctl show-session 2 -p Type

Code: Select all

Type=x11
Should it start Xsession instead? If yes, how do I change it?

Looks like I may have fixed it. I uninstalled sddm-config-editor-git and sddm. Then I deleted any system files and directories for sddm. Then reinstalled sddm and rebooted. I've booted a couple of times so far without issue.

I can re-create the issue by entering my name in the "Username for autologin session". When login freezes, I go into tty and edit the "sddm.conf" to remove my name. Run "sudo systemctl restart sddm.service" and the login screen appears.

Where can I get the "arcolinux-sddm-archpaint" login theme?

Post Reply

Return to “General Questions”