ArcoLinux -D -B 19.5 iso's have been released

[SOLVED] NVIDIA DRIVERS AND MELTDOWN AND SPECTRE

Post Reply
ArchMergeAwesomeness
recruit crewman
Posts: 1
Joined: Tue Jan 16, 2018 7:39 pm
United States of America
[SOLVED] NVIDIA DRIVERS AND MELTDOWN AND SPECTRE

Post by ArchMergeAwesomeness » Tue Jan 16, 2018 7:50 pm

First of all, is ArchMerge or ArchMergeD effected by Meltdown and Spectre?
Is the NVIDIA-304xx driver that I use patched to ward against data breaches from Meltdown and Spectre?
Is there an alternative driver that I can use besides NVIDIA-304xx since NVIDIA-384 isn't listed in either the Arch repository or in the AUR?
Firefox 57.04's already installed.

User avatar
erikdubois
Captain
Posts: 2101
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] NVIDIA DRIVERS AND MELTDOWN AND SPECTRE

Post by erikdubois » Wed Jan 17, 2018 6:15 am

Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

nickpetrov
Commander
Posts: 55
Joined: Thu Nov 09, 2017 9:04 am
Canada
Re: [OPEN] NVIDIA DRIVERS AND MELTDOWN AND SPECTRE

Post by nickpetrov » Thu Jan 18, 2018 3:39 am

All OS's are affected by Meltdown & Spectre---Windows, Linux, Mac OS, Android, IOS...etc

Spectre could affect GPU's, But Spectre is more difficult to exploit and there are no reports of it being used outside of lab and proof-of-concept cyber attacks.
so just in case make sure you have the latest video card drivers from either arch or AUR (nothing else you can do).

Every Intel Cpu dated back to 1995 is affected by Meltdown and Spectre and even AMD and Arm processors could be affected by Spectre. Upstream has patched the kernel for Meltdown, last week. However you also need the new Intel microcode installed as well. The command for that is "sudo pacman -S intel-ucode" and then update grub.

Code: Select all

sudo pacman -S intel-ucode
sudo grub-mkconfig -o /boot/grub/grub.cfg'
starting with kernel 4.14.14 and 4.9.77-lts upstream has started patching it for the 2nd variant of the attack Spectre.

also if you use Chromium or Google Chrome it would be a good idea to turn on site isolation, helps against these attacks as well, it sandboxes each site in it's own process. Hardens things up a little more. You can do this by typing this in the address bar: chrome://flags#enable-site-per-process, click Enable, and restart

so, just make sure you take all Archmerge & ArchMergeD updates and make sure you have the latest kernel and Intel microcode installed


Post Reply

Return to “Graphical Drivers (Nvidia,...)”