ArcoLinux -D -B 19.5 iso's have been released

[SOLVED] Swap Dependency Error at Boot

Post Reply
User avatar
UOOP
Crewman
Posts: 16
Joined: Wed Feb 21, 2018 11:30 am
United States of America
[SOLVED] Swap Dependency Error at Boot

Post by UOOP » Fri Feb 23, 2018 6:14 am

So as my name displays, I am new to Linux and ArchMerge. I have a Sony Vaio laptop with 6 Gb of RAM, running ArchMerge 6.3.1. I removed the swap partition on my drive as I did not see a reason for it (swap is usually recommended for >= 1Gb of RAM). On the next boot, the system stated some app was looking for a specific item (please see link at bottom). The process timed out and then stated the swap dependency timed out and failed. Is there any way to remove/disable this check/error without partitioning a swap?

Google Drive Link:
https://drive.google.com/file/d/1FOpTiX ... sp=sharing
Last edited by UOOP on Sat Feb 24, 2018 4:51 am, edited 1 time in total.

User avatar
TheWanderer
Crewman
Posts: 15
Joined: Wed Jan 10, 2018 10:59 am
Hungary
Re: Swap Dependency Error at Boot

Post by TheWanderer » Fri Feb 23, 2018 8:59 am

You should comment out the swap section in /etc/fstab

Code: Select all

sudo nano /etc/fstab 
And put # at the begining of the swap's line

User avatar
UOOP
Crewman
Posts: 16
Joined: Wed Feb 21, 2018 11:30 am
United States of America
Re: Swap Dependency Error at Boot

Post by UOOP » Sat Feb 24, 2018 4:51 am

Thanks! Worked perfectly :D
Linux4life


Post Reply

Return to “Tips and Tricks”