ArcoLinux -D -B 19.11 has been released

[SOLVED] Cannot update after fresh install because of new kernel 4.20

Post Reply
airbutre
Crewman
Posts: 26
Joined: Mon Mar 12, 2018 12:38 pm
Austria
[SOLVED] Cannot update after fresh install because of new kernel 4.20

Post by airbutre » Mon Dec 31, 2018 3:38 pm

Strange things happening at the end of 2018 :shock:

Code: Select all

[pad@pad-pc ~]$ sudo pacman -Syy
:: Synchronizing package databases...
 core                                        133.8 KiB  1487K/s 00:00 [--------------------------------------] 100%
 extra                                      1695.0 KiB  8.85M/s 00:00 [--------------------------------------] 100%
 community                                     4.8 MiB  9.78M/s 00:00 [--------------------------------------] 100%
 multilib                                    174.8 KiB  2.55M/s 00:00 [--------------------------------------] 100%
 arcolinux_repo                               24.4 KiB  1017K/s 00:00 [--------------------------------------] 100%
 arcolinux_repo.sig                          310.0   B  0.00B/s 00:00 [--------------------------------------] 100%
 arcolinux_repo_3party                         6.0 KiB  2000K/s 00:00 [--------------------------------------] 100%
 arcolinux_repo_3party.sig                   310.0   B  0.00B/s 00:00 [--------------------------------------] 100%
 arcolinux_repo_submicron                      9.9 KiB  3.23M/s 00:00 [--------------------------------------] 100%
 arcolinux_repo_submicron.sig                309.0   B  0.00B/s 00:00 [--------------------------------------] 100%

[pad@pad-pc ~]$ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 arcolinux_repo is up to date
 arcolinux_repo_3party is up to date
 arcolinux_repo_submicron is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'linux<4.20' required by deepin-anything-module
[pad@pad-pc ~]$ 
Any helpful advice will be appreciated.
cu
airbutre
Last edited by airbutre on Tue Jan 01, 2019 6:36 pm, edited 1 time in total.

User avatar
erikdubois
Captain
Posts: 2639
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Cannot update after fresh install because of new kernel 4.20

Post by erikdubois » Mon Dec 31, 2018 8:13 pm

In this case you just need to wait

The developer needs to create a new package for linux kernel 4.20.

The same happened with Virtualbox dependencies.

Special days -- give them some time.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

User avatar
erikdubois
Captain
Posts: 2639
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Cannot update after fresh install because of new kernel 4.20

Post by erikdubois » Mon Dec 31, 2018 8:14 pm

https://www.archlinux.org/packages/comm ... ng-module/

Should be ok now

check dependencies
linux>=4.20
linux<4.21
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

airbutre
Crewman
Posts: 26
Joined: Mon Mar 12, 2018 12:38 pm
Austria
Re: [OPEN] Cannot update after fresh install because of new kernel 4.20

Post by airbutre » Tue Jan 01, 2019 6:36 pm

After waiting 'a year ' :lol: it works now. Thanks again, Erik!

cu
airbutre

User avatar
erikdubois
Captain
Posts: 2639
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [SOLVED] Cannot update after fresh install because of new kernel 4.20

Post by erikdubois » Tue Jan 01, 2019 7:23 pm

lol
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.


Post Reply

Return to “BYOI ArcoLinuxB Deepin”