[SOLVED] mirrorlist keep resetting

First check the forums - Do not know where to put it then put it here
Post Reply
belred
recruit crewman
Posts: 2
Joined: Thu May 21, 2020 9:08 pm

[SOLVED] mirrorlist keep resetting

Post by belred »

I have the mirrorlist the way I like it. I've updated the mirror alias in .bashrc to the reflector command I want. I've updated /usr/local/bin/update-mirrors to use the reflector command I want. I've even disabled the update-mirrors systemd service. But still there are times when the system updates with some package that I can't figure out, it updates the mirrorlist. But when it does update the mirrors, it always ignores my reflector options and goes back to the default reflector command which I don't want and is slow.

This is the reflector command it's running which I don't want. I don't know where this command keeps coming from.
reflector -f 99 -l 99 --number 50 --save /etc/pacman.d/mirrorlist

After the system updates to the previous settings, I always rerun it again with the command I do want.
reflector -phttps -cUS -a8 -f10 --sort rate --save /etc/pacman.d/mirrorlist

My question is how do I stop this automatic changing of my mirrorlist and changing of my reflector command.

I'm using ArcoLinuxB Gnome edition.

User avatar
erikdubois
Captain
Posts: 3149
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] mirrorlist keep resetting

Post by erikdubois »

remove the cron job

Code: Select all

sudo pacman -R arcolinux-cron-git
and remove the service

Code: Select all

sudo systemctl disable update-mirrors.service
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

belred
recruit crewman
Posts: 2
Joined: Thu May 21, 2020 9:08 pm

Re: [OPEN] mirrorlist keep resetting

Post by belred »

Thank you. I had disabled the service, but didn't know about the cronjob.

Post Reply

Return to “General Questions”