ArcoLinux 19.09 iso has been released

[OPEN] ArcLinuxD ISO and ACPI errors on boot

Post Reply
foszoe
Crewman
Posts: 4
Joined: Sat Jun 08, 2019 8:28 pm
United States of America
[OPEN] ArcLinuxD ISO and ACPI errors on boot

Post by foszoe » Sat Jun 08, 2019 8:33 pm

I never make it to the graphical installer due to several ACPI errors that result in me dropping into a terminal. Has anyone ever had such an issue? Trying again with an ArcoLinuxB iso but expect to get the same error. Will post more specifics later. Ran Gentoo a decade ago but on laptops I dislike compiling but I do like rolling distros. Was running Antergos until it was abandoned so thats how I got to Arco.

User avatar
erikdubois
Captain
Posts: 2514
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] ArcLinuxD ISO and ACPI errors on boot

Post by erikdubois » Sun Jun 09, 2019 7:08 am

Check again if there is not anything else in there.

many people get these acpi errors - kernel normally just skips them and moves on

normally unimportant

but

is there anything else....

a dmesg printout on pastebin.com and we can have a look together
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

foszoe
Crewman
Posts: 4
Joined: Sat Jun 08, 2019 8:28 pm
United States of America
Re: [OPEN] ArcLinuxD ISO and ACPI errors on boot

Post by foszoe » Sun Jun 09, 2019 11:59 am

It took some time but Google and I figured it out.

The image file names were not matching so it would not mount.
The relevant information:
Mounting /dev/disk/by-label/alb-plasma-min-v19.06.1-x86_64' to '/run/archiso/bootmnt'
Waiting 30 seconds for device ‘/dev/disk/by-label/alb-plasma-min-v19.06.1-x86_64’ …
No caching mode page found
Assuming drive cache: write through
ERROR: ‘/dev/disk/by-label/alb-plasma-min-v19.06.1-x86_64’ device did not show up after 30 seconds…
the fix is to
cd /dev/disk/bylabel
mv ALB-PLASMA- alb-plasma-min-v19.06.1-x86_64
exit
The image file doesn't match what the script is looking for. the 'alb-plasma-min-v19.06.1-x86_64' is of course a ArcoLinuxB iso but i was trying several and it was the last. the name of the image will change depending on the iso, whether it's a D or a B iso and the customization selected.

User avatar
erikdubois
Captain
Posts: 2514
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] ArcLinuxD ISO and ACPI errors on boot

Post by erikdubois » Sun Jun 09, 2019 1:19 pm

You moved a file name from Capital letters to small letters.
Is that the solution?

What did you burn it with?
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

foszoe
Crewman
Posts: 4
Joined: Sat Jun 08, 2019 8:28 pm
United States of America
Re: [OPEN] ArcLinuxD ISO and ACPI errors on boot

Post by foszoe » Sun Jun 09, 2019 2:08 pm

Yes.
I used Rufus to burn the iso to an external usb ssd.

When the usb ssd booted, it would not boot into Linux but dropped me into a "rootfs" prompt because it could not find the disk image to mount. By changing the image name to match what the name of the file it was trying to mount, it worked.
cd /dev/disk/bylabel
mv ALB-PLASMA- alb-plasma-min-v19.06.1-x86_64
exit
The exit command allowed the computer to mount the newly renamed image file and continue to boot into the ArcoLinux installer

User avatar
erikdubois
Captain
Posts: 2514
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] ArcLinuxD ISO and ACPI errors on boot

Post by erikdubois » Sun Jun 09, 2019 3:55 pm

You do mean USB SSD and not just a usb.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

foszoe
Crewman
Posts: 4
Joined: Sat Jun 08, 2019 8:28 pm
United States of America
Re: [OPEN] ArcLinuxD ISO and ACPI errors on boot

Post by foszoe » Sun Jun 09, 2019 5:08 pm

Correct. I am using a USB SSD.

I've used the same solution on the ArcoLinuxD and ArcoLinuxB ISOs.

User avatar
erikdubois
Captain
Posts: 2514
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] ArcLinuxD ISO and ACPI errors on boot

Post by erikdubois » Mon Jun 10, 2019 7:45 am

Have you tried a regular usb to see if it is easier to install without manual intervention.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.


Post Reply

Return to “Installation issues of ArcoLinuxD iso”