Santa brings you ArcoLinux -D -B 19.12

[SOLVED] Decryption time too long

fhins
Crewman
Posts: 38
Joined: Sun Apr 14, 2019 3:54 pm
United States of America
[SOLVED] Decryption time too long

Post by fhins » Mon Jun 24, 2019 1:27 am

I installed the ArcoLinux KDE 19.06 on my computer, and glad to see the encryption is now working! How ever it takes at least 17-18 seconds to get to the "ArcoLinuxB" login screen after you enter the passphrase. The same process with Antergos only took only a few seconds which was also an Arch based system. I hope some day (hopefully soon) the decryption time can get reduced to a few seconds like Antergos used to be!

P.S. The over all boot time is fine after the system passes the Grub decryption. It's just the the initial 17 or 18 seconds.
systemd-analyze
Startup finished in 6.144s (kernel) + 1.262s (userspace) = 7.407s
graphical.target reached after 1.251s in userspace

Code: Select all

systemd-analyze blame
           557ms systemd-logind.service
           504ms lightdm.service
           400ms lvm2-monitor.service
           339ms dev-mapper-luks\x2d4d92d6cd\x2df54d\x2d455c\x2dbf66\x2d86b04129dd73.device
           202ms udisks2.service
           178ms systemd-udevd.service
           174ms upower.service
           164ms systemd-journald.service
           121ms ldconfig.service
            89ms org.cups.cupsd.service
            79ms polkit.service
            58ms systemd-udev-trigger.service
            52ms NetworkManager.service
            47ms systemd-modules-load.service
            44ms avahi-daemon.service
            42ms systemd-tmpfiles-clean.service
            26ms systemd-journal-catalog-update.service
            24ms user@1000.service
            21ms systemd-sysusers.service
            19ms systemd-binfmt.service
            19ms systemd-journal-flush.service
            17ms systemd-tmpfiles-setup.service
            14ms sys-kernel-debug.mount
            13ms colord.service
            13ms dev-mqueue.mount

User avatar
erikdubois
Captain
Posts: 2685
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Decryption time too long

Post by erikdubois » Mon Jun 24, 2019 8:07 am

Encryption is NOT my strong-suite at all.

If others can find a solution, that would be appreciated.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

fhins
Crewman
Posts: 38
Joined: Sun Apr 14, 2019 3:54 pm
United States of America
Re: [OPEN] Decryption time too long

Post by fhins » Tue Jun 25, 2019 2:45 pm

I'm assuming that this is something that "Calamares" developers need to improve upon. So I hope the information I provided was useful.

fhins
Crewman
Posts: 38
Joined: Sun Apr 14, 2019 3:54 pm
United States of America
[FOLLOW-UP] Decryption time too long

Post by fhins » Sat Jul 20, 2019 6:24 pm

I have posted this issue under the "Plasma" section, and you'd mentioned that there is no immediate solution to improve the decryption speed after you enter the key (takes about 18 seconds to get to the login screen). I just tried the 19.07 version, hoping that there may be some improvement in that regard, but it still took about the 18 seconds. I know Antergos was using a different installer, but it only took a few seconds to decrypt the system and get into the login screen. Even though this is not be a priority, but I hope the developers could look into this some time in the near future.

User avatar
erikdubois
Captain
Posts: 2685
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [FOLLOW-UP] Decryption time too long

Post by erikdubois » Sat Jul 20, 2019 7:02 pm

we know

we will
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

User avatar
erikdubois
Captain
Posts: 2685
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [FOLLOW-UP] Decryption time too long

Post by erikdubois » Sun Jul 21, 2019 11:12 am

moved post together here

spend the better half of the day reading... and testing

https://github.com/calamares/calamares/wiki/Deploy-LUKS

I think we have set it all except one thing

GRUB_ENABLE_CRYPTODISK: true in the grubcfg.conf

but changing that in calamares did not improve decryption time - here 15 seconds
nor did changing the /etc/default/grub setting and build an iso that way...

We need assistance from Calamares or somebody well versed in encryption to know what we are missing.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

User avatar
erikdubois
Captain
Posts: 2685
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [FOLLOW-UP] Decryption time too long

Post by erikdubois » Sun Jul 21, 2019 11:14 am

Code: Select all

[erik@ArcoLinux ~]$ systemd-analyze blame 
           498ms lvm2-monitor.service
           364ms dev-mapper-luks\x2d56d1df02\x2d2646\x2d44df\x2db5a6\x2d0de84cc5f58d.device
           289ms lightdm.service
           260ms systemd-logind.service
           178ms systemd-udevd.service
           156ms systemd-journald.service
           144ms accounts-daemon.service
           138ms NetworkManager.service
           112ms polkit.service
            90ms ldconfig.service
            73ms virtual-machine-check.service
            72ms user@1000.service
            71ms avahi-daemon.service
            70ms udisks2.service
            46ms systemd-udev-trigger.service
            40ms upower.service
            32ms org.cups.cupsd.service
            28ms dev-mqueue.mount
            27ms systemd-sysusers.service
            27ms systemd-modules-load.service
            21ms systemd-journal-flush.service
            20ms systemd-tmpfiles-setup.service
            17ms systemd-journal-catalog-update.service
            15ms sys-kernel-debug.mount
            14ms ntpd.service
            13ms systemd-random-seed.service
            13ms systemd-tmpfiles-setup-dev.service
            12ms user-runtime-dir@1000.service
            12ms sys-fs-fuse-connections.mount
            11ms systemd-remount-fs.service
            10ms kmod-static-nodes.service
            10ms sys-kernel-config.mount
            10ms systemd-sysctl.service
             9ms dev-hugepages.mount
             9ms systemd-user-sessions.service
             8ms systemd-cryptsetup@luks\x2d56d1df02\x2d2646\x2d44df\x2db5a6\x2d0de84cc5f58d.service
             8ms haveged.service
             7ms systemd-update-utmp.service
             6ms tmp.mount
             6ms rtkit-daemon.service
             5ms systemd-update-done.service
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

User avatar
erikdubois
Captain
Posts: 2685
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Decryption time too long

Post by erikdubois » Sun Jul 21, 2019 1:46 pm

I think I found the solution

Do a manual configuration like this

Separate /boot without encryption improves boot-up time - same time as not encrypted setup

If you try this, can you confirm that this works?



Calamares installer 3.2.10
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

User avatar
erikdubois
Captain
Posts: 2685
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Decryption time too long

Post by erikdubois » Sun Jul 21, 2019 1:56 pm

If you try this, can you confirm that this works?
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

fhins
Crewman
Posts: 38
Joined: Sun Apr 14, 2019 3:54 pm
United States of America
Re: [OPEN] Decryption time too long

Post by fhins » Mon Jul 22, 2019 1:44 am

@ Erik,

I followed your video step by step and installed it manually on a new computer. How ever, it took about the same 18 seconds to get to the login screen. I only encrypted ext4, and not the boot. I don't know what kind of installer Antergos was using, but by far it had the fastest boot time of any distribution I'd tried, and I have tried them all (KDE) that is. Thanks for taking the time, and making that video. I'm going to test it, and see if I'd done something wrong.

Second installation: Same 18 seconds to get to the login screen.


Post Reply

Return to “Calamares”