[OPEN] Widget not working with ryzen 3200x

Post Reply
pete051
recruit crewman
Posts: 2
Joined: Fri Jul 24, 2020 6:17 pm

[OPEN] Widget not working with ryzen 3200x

Post by pete051 »

I'm running ArcolinuxB on my laptop and ArcolinuxD on my desktop, the problem is that the CPU temp widgit on Awesome desktop works fine on dual core celeron laptop but not at all on the Ryzen 3200x on the desktop.
According to .config/awesome/lain/widget/temp.lua the path for the sensor is /sys/devices/virtual/thermal/thermal_zone0/temp which is correct for the laptop but the desktop only has the files /sys/devices/virtual/thermal containing 4 folders cooling_device0 to cooling_device3 but no thermal_zone0 which explains why it's not working but I wonder why they aren't there is the 3 series Ryzen to new for the kernel? or is there anybody with a Ryzen processor that has it working?
if so please let me know how you did it :)

User avatar
erikdubois
Captain
Posts: 3332
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] Widget not working with ryzen 3200x

Post by erikdubois »

yes you got to change where it points to

everyone will have to adjust it to their hardware
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

pete051
recruit crewman
Posts: 2
Joined: Fri Jul 24, 2020 6:17 pm

Re: [OPEN] Widget not working with ryzen 3200x

Post by pete051 »

I appreciate that, the problem is finding out where it should point to. I have run sensor-detect and that tells me the modules are loaded, I have tried find / temp with no result. xsensor gives me a reading but it seems unlikely 100 degrees C on some cores. Ok the lack is not important :)

Post Reply

Return to “Awesome”