[OPEN] No audio through Audio Jack to headphones. Audio Problem

Post Reply
JustHipo
recruit crewman
Posts: 2
Joined: Sun Aug 09, 2020 1:23 am

[OPEN] No audio through Audio Jack to headphones. Audio Problem

Post by JustHipo »

Installed arcolinux yesterday and though I could get audio playing through the speakers, Couldnt get the Headphones Jack to play audio to my Headphones.
Tried fixing through alsamixer by unmuting speakers, checked outpút devices aon pavucontrol and tried a solujtion on a similar problem I found on the archlinux reddit by running $ alsactl restore. nothing has worked so far

tried running stop pulseaudio aswell, still nothing. Speaker-test works for the computer speakers but not for the headphones.

running Linux on a mid-2011 Imac computer

heres output for aplay:

Code: Select all

 [qcu@Justqcu ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CS4206 Analog [CS4206 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: CS4206 Digital [CS4206 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0 
LSPCI:

Code: Select all

 [qcu@Justqcu ~]$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 Display controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Universal Host Controller #5 (rev 05)
00:1a.7 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Universal Host Controller #1 (rev 05)
00:1d.7 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation Z68 Express Chipset LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port Desktop SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series]
02:00.0 Ethernet controller: Broadcom Inc. and subsidiaries NetXtreme BCM57765 Gigabit Ethernet PCIe (rev 10)
03:00.0 Network controller: Qualcomm Atheros AR93xx Wireless Network Adapter (rev 01)
04:00.0 FireWire (IEEE 1394): LSI Corporation FW643 [TrueFire] PCIe 1394b Controller (rev 08)
05:00.0 PCI bridge: Intel Corporation CV82524 Thunderbolt Controller [Light Ridge 4C 2010]
06:00.0 PCI bridge: Intel Corporation CV82524 Thunderbolt Controller [Light Ridge 4C 2010]
06:03.0 PCI bridge: Intel Corporation CV82524 Thunderbolt Controller [Light Ridge 4C 2010]
06:04.0 PCI bridge: Intel Corporation CV82524 Thunderbolt Controller [Light Ridge 4C 2010]
06:05.0 PCI bridge: Intel Corporation CV82524 Thunderbolt Controller [Light Ridge 4C 2010]
06:06.0 PCI bridge: Intel Corporation CV82524 Thunderbolt Controller [Light Ridge 4C 2010]
07:00.0 System peripheral: Intel Corporation CV82524 Thunderbolt Controller [Light Ridge 4C 2010]
09:00.0 PCI bridge: Intel Corporation DSL2210 Thunderbolt Controller [Port Ridge 1C 2011]
0a:00.0 PCI bridge: Intel Corporation DSL2210 Thunderbolt Controller [Port Ridge 1C 2011]
0b:00.0 SATA controller: ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 01) 



Code: Select all

 [qcu@Justqcu ~]$ speaker-test -c 2 -D front:CARD=PCH,DEV=0

speaker-test 1.2.3

Playback device is front:CARD=PCH,DEV=0
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 8544000
Period size range from 32 to 4272000
Using max buffer size 8544000
Periods = 4
Unable to set hw params for playback: Cannot allocate memory
Setting of hwparams failed: Cannot allocate memory 



aplay -L:

Code: Select all

 [qcu@Justqcu ~]$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
samplerate
    Rate Converter Plugin Using Samplerate Library
speexrate
    Rate Converter Plugin Using Speex Resampler
jack
    JACK Audio Connection Kit
oss
    Open Sound System
pulse
    PulseAudio Sound Server
speex
    Plugin using Speex DSP (resample, agc, denoise, echo, dereverb)
upmix
    Plugin for channel upmix (4,6,8)
vdownmix
    Plugin for channel downmix (stereo) with a simple spacialization
default
    Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=PCH
    HDA Intel PCH, CS4206 Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, CS4206 Analog
    Front output / input
surround21:CARD=PCH,DEV=0
    HDA Intel PCH, CS4206 Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, CS4206 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, CS4206 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, CS4206 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, CS4206 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, CS4206 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=PCH,DEV=0
    HDA Intel PCH, CS4206 Digital
    IEC958 (S/PDIF) Digital Audio Output
usbstream:CARD=PCH
    HDA Intel PCH
    USB Stream Output
hdmi:CARD=HDMI,DEV=0
    HDA ATI HDMI, HDMI 0
    HDMI Audio Output
usbstream:CARD=HDMI
    HDA ATI HDMI
    USB Stream Output 

vcaselli
Crewman
Posts: 22
Joined: Sat Dec 14, 2019 8:25 am
Location: Livorno
Contact:

Re: No audio through Audio Jack to headphones. Audio Problem

Post by vcaselli »

I have a similar problem, but with ArcolinuxB Deepin.
All was working ok for months until some update around 8 or 9 august 2020.
Now in Control Center, Sounds, I cannot set output and input devices (the lists are just empty).
Indeed the audio output is working, but the mics are not.
Any hints?

User avatar
sleepyeyesvince
Crewman
Posts: 13
Joined: Thu Oct 10, 2019 3:43 pm

Re: [OPEN] No audio through Audio Jack to headphones. Audio Problem

Post by sleepyeyesvince »

I've had intermittent issues with recent update as well. Not with every boot.
Have you tried running the command

Code: Select all

pulseaudio -k
Check Sound control panel

Code: Select all

pavucontrol
to see your devices are correctly detected and settings are right.

Otherwise I wonder if it is a recent kernel issue. I'm not that good with changing pulseaudio settings files, but there might be an answer if you look for setting default-sink or default-source in /etc/pulse/default.pa as outlined here https://wiki.archlinux.org/index.php/Pu ... utput_sink

JustHipo
recruit crewman
Posts: 2
Joined: Sun Aug 09, 2020 1:23 am

Re: [OPEN] No audio through Audio Jack to headphones. Audio Problem

Post by JustHipo »

SOLVED
The solution to the problem was to specify the system I was running arco in (IMac mid-2011) following the arch wiki's IMAC page and troubleshooting from there with pavucontrol.

Post Reply

Return to “Audio”