ArcoLinux -D -B 19.11 has been released

[OPEN] Dell laptop crashing back to Login

Post Reply
recruit crewman
Posts: 2
Joined: Thu Nov 22, 2018 5:01 pm
United States of America
[OPEN] Dell laptop crashing back to Login

Post by dhayes » Thu Nov 22, 2018 7:17 pm

Hello All. Loving ArcoLinuxB with minimal KDE. But I have a vexing issue that has plagued me on all Arch distros I have tried (Mangaro, Antergos, etc). This does not happen on any other non arch distro. Basically, I have a 2015 Dell XPS 13 developer edition with latest BIOS, etc. What happens is that at random times the system will crash me out of all my apps and kick me back to a login screen. This is especially bad since I am running virtual box and have several VM's that crash hard into an aborted state. Based on my testing back in July this seems to be related to power settings and possibly PowerDevil. I would love to figure this out because Arco is by far the best distro I have run especially with KDE plasma on top. Listed below is some info that might help right after it happened.

Thanks for any help you might have.


# inxi -Fxzc0
System: Host: cedge1 Kernel: 4.19.2-arch1-1-ARCH x86_64 bits: 64 compiler: gcc v: 8.2.1
Desktop: KDE Plasma 5.14.3 Distro: ArcoLinuxB-plasma-min v18.11.2
Machine: Type: Laptop System: Dell product: XPS 13 9343 v: N/A serial: <filter>
Mobo: Dell model: 0TM99H v: A00 serial: <filter> UEFI: Dell v: A17 date: 05/23/2018
Battery: ID-1: BAT0 charge: 32.8 Wh condition: 32.8/52.7 Wh (62%) model: SMP DELL RWT1R43
status: Full
CPU: Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell
rev: 4 L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17566
Speed: 2494 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 2494 2: 2494 3: 2494 4: 2494
Graphics: Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
Display: x11 server: X.Org 1.20.3 driver: intel unloaded: fbdev,modesetting,vesa tty: N/A
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio: Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel v: kernel
bus ID: 00:03.0
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell driver: snd_hda_intel
v: kernel bus ID: 00:1b.0
Sound Server: ALSA v: k4.19.2-arch1-1-ARCH
Network: Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: f040 bus ID: 02:00.0
IF: wlp2s0 state: up mac: <filter>
Drives: Local Storage: total: 238.47 GiB used: 148.27 GiB (62.2%)
ID-1: /dev/sda vendor: Samsung model: SSD PM851 M.2 2280 256GB size: 238.47 GiB
Partition: ID-1: / size: 224.77 GiB used: 148.23 GiB (65.9%) fs: ext4 dev: /dev/dm-0
ID-2: swap-1 size: 8.80 GiB used: 47.2 MiB (0.5%) fs: swap dev: /dev/dm-1
Sensors: System Temperatures: cpu: 74.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info: Processes: 228 Uptime: 1d 23h 38m Memory: 7.70 GiB used: 5.15 GiB (66.9%) Init: systemd
Compilers: gcc: 8.2.1 clang: 7.0.0 Shell: bash v: 4.4.23 inxi: 3.0.27

# journalctl -g PowerDevil
-- Logs begin at Tue 2018-11-20 10:55:06 EST, end at Thu 2018-11-22 10:34:34 EST. --
Nov 20 10:55:14 cedge1 kdeinit5[943]: kscreen.kded: PowerDevil SuspendSession action not available!
Nov 22 10:26:23 cedge1 kdeinit5[9264]: kscreen.kded: PowerDevil SuspendSession action not available!

recruit crewman
Posts: 2
Joined: Thu Nov 22, 2018 5:01 pm
United States of America
Re: [OPEN] Dell laptop crashing back to Login

Post by dhayes » Fri Nov 23, 2018 8:15 pm

Hello...Found this on Arch wiki.

I will try the first fix under troubleshooting and see what happens. So far all has been well.

I will post back my results.


User avatar
Posts: 2671
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Re: [OPEN] Dell laptop crashing back to Login

Post by erikdubois » Fri Nov 23, 2018 8:20 pm

Good luck.
Was busy developing.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on
then use the power of google
then use the power of our moderators.

User avatar
Posts: 27
Joined: Thu Nov 22, 2018 12:18 am
United States of America
Re: [OPEN] Dell laptop crashing back to Login

Post by JBrewer » Sat Dec 01, 2018 2:36 pm

I run an Asus ROG laptop. The kernel has been giving me gruff about power manager not quite like what you have but similar. I disables acpi in the kernel command line.
By adding pci=noacpi in the grub command line.

Code: Select all

ACPI stands for Advanced Configuration and Power Interface. It is the system that controls hardware actions such as the dynamic speed fans, the power button behavior, system sleep states, and helps to identify some system capabilities.

ACPI power-saving features are hierarchical, meaning that any device running "behind" another will be dependent on the power state of the parent device. For example, a device cannot be running in full-power "behind" a device that is sleeping or in stand-by mode.

However, many hardware platforms ship with buggy or out-of-specification ACPI firmware which can cause any number of unspecified problems. If the machine is randomly powering off or failing to boot, disabling ACPI may help.

The consequences are that when ACPI is off, the server will be unable to turn itself off, as the soft shutdown cannot work after executing poweroff or shutdown -h now. It will be necessary to press/hold the shutdown/reboot button of that server, or power off via Out-of-Band management.
as taken from

Post Reply

Return to “Laptop”