[OPEN] Webcam microphone not working

Post Reply
Arcotron5000
recruit crewman
Posts: 2
Joined: Sun Sep 06, 2020 12:12 pm

[OPEN] Webcam microphone not working

Post by Arcotron5000 »

ArcoLinux is able to pick up my webcam and the video works perfectly in every application I have tried it.
The microphone does not. It is listed in the audio mixer but it does not register any sound.
When I disconnect and reconnect the webcam it registers the microphone no problem and everything works very well, but as soon as I log out/reboot it stops working again.

System info:
OS: ArcoLinux
Kernel: 5.8.7-arch1-1
DE: Xfce 4.14

Possibly useful logs:

The output of dmesg after reconnecting the webcam:

Code: Select all

...
[ 1104.595626] usb 3-4: 3:1: cannot get freq at ep 0x84
[ 1104.655626] usb 3-4: 3:1: cannot get freq at ep 0x84
[ 1159.586631] usb 3-4: USB disconnect, device number 4
[ 1159.586845] usb 3-4: cannot submit urb (err = -19)
[ 1159.596600] usb 3-4: cannot submit urb 0, error -19: no device
...
[ 1163.546543] usb 3-4: new high-speed USB device number 5 using xhci_hcd
[ 1163.907791] usb 3-4: New USB device found, idVendor=0c45, idProduct=6366, bcdDevice= 1.00
[ 1163.907794] usb 3-4: New USB device strings: Mfr=2, Product=1, SerialNumber=3
[ 1163.907796] usb 3-4: Product: USB Camera
[ 1163.907797] usb 3-4: Manufacturer: USB Camera
[ 1163.907798] usb 3-4: SerialNumber: SN0001
[ 1163.914781] uvcvideo: Found UVC 1.00 device USB Camera (0c45:6366)
[ 1163.955741] uvcvideo 3-4:1.0: Entity type for entity Extension 4 was not initialized!
[ 1163.955745] uvcvideo 3-4:1.0: Entity type for entity Extension 3 was not initialized!
[ 1163.955747] uvcvideo 3-4:1.0: Entity type for entity Processing 2 was not initialized!
[ 1163.955749] uvcvideo 3-4:1.0: Entity type for entity Camera 1 was not initialized!
[ 1163.955860] input: USB Camera: USB Camera as /devices/pci0000:00/0000:00:01.2/0000:02:00.0/0000:03:08.0/0000:05:00.3/usb3/3-4/3-4:1.0/input/input20
[ 1163.994541] usb 3-4: 3:1: cannot get freq at ep 0x84
...
hwinfo --usb

Code: Select all

03: USB 00.2: 0000 Unclassified device
  [Created at usb.122]
  Unique ID: YBiL.22Nr4EI0e11
  Parent ID: uIhY.buxry1DL_88
  SysFS ID: /devices/pci0000:00/0000:00:01.2/0000:02:00.0/0000:03:08.0/0000:05:00.3/usb3/3-4/3-4:1.2
  SysFS BusID: 3-4:1.2
  Hardware Class: unknown
  Model: "Microdia USB Camera"
  Hotplug: USB
  Vendor: usb 0x0c45 "Microdia"
  Device: usb 0x6366 "USB Camera"
  Revision: "1.00"
  Serial ID: "SN0001"
  Driver: "snd-usb-audio"
  Driver Modules: "snd_usb_audio"
  Speed: 480 Mbps
  Module Alias: "usb:v0C45p6366d0100dcEFdsc02dp01ic01isc01ip00in02"
  Driver Info #0:
    Driver Status: snd_usb_audio is active
    Driver Activation Cmd: "modprobe snd_usb_audio"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #5 (Hub)

User avatar
erikdubois
Captain
Posts: 3409
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] Webcam microphone not working

Post by erikdubois »

I got my webcam that was not working at some point in time

went from linux kernel to linux-lts kernel and it was fixed

in the meantime the linux kernels gives me back my webcam

so

try out another kernel

linux
linux-lts
linux-zen
linux-hardened

or

downgrade the kernel until everything works
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

Arcotron5000
recruit crewman
Posts: 2
Joined: Sun Sep 06, 2020 12:12 pm

Re: [OPEN] Webcam microphone not working

Post by Arcotron5000 »

Thank you for the advice.

I tried installing linux-lts and linux-zen but there was no change.

What is curious is that it only picks up the microphone when an application is open that is actively looking for it.
For example if I just unplug the webcam and plug it back in again the microphone still won't work, but if I do that with zoom open then the microphone starts working again.

User avatar
erikdubois
Captain
Posts: 3409
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] Webcam microphone not working

Post by erikdubois »

omg is the right response
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

Post Reply

Return to “Kernel & Hardware”