ArcoLinux 19.09 iso has been released

[OPEN] - UPDATED - Fresh install but no sound, whatever I do

Post Reply
Adrian_Nedelcu
recruit crewman
Posts: 2
Joined: Fri Sep 27, 2019 1:09 pm
Italy
[OPEN] - UPDATED - Fresh install but no sound, whatever I do

Post by Adrian_Nedelcu » Fri Sep 27, 2019 11:44 pm

Hello

I start by saying the I love ArchLinux and I love this flavour of it, the ArcoLinux. After Antergos, I find it a very valid substitute.
But... I have a problem which manifests in every distribution based on ArchLinux.

I am running ArcoLinux on a Lenove IdeaPad 330-17AST laptop. It's not brand new, May 2018 only. And thus, it has no (complete) support of the ArchLinux community and it's not supported by the OEM.

I have mainly two problems: one with the WiFi card, a RLT8821CE and one with the sound card.
While the first can be overcome by a series of tweaks - first installing linux-headers, then installing dkms and finally installing from AUR the dedicated driver, the second one is driving me crazy because I've tried every logical and sane solution found.
But yet: NO SOUND. The speaker icon is grayed out while hovering over it says "Not connected to the PulseAudio server".
In case it could help I will list here various listings of my sound related modules and hardware.

My computer:
OS: ArcoLinux v19.07.11
Kernel: 5.3.1-arch1-1-ARCH
Uptime: 7 mins
Packages: 1229 (pacman), 24 (bonsai)
Shell: bash 5.0.9
Resolution: 1600x900
DE: Xfce
WM: Xfwm4
WM Theme: Arc-Dark
Theme: Arc-Dark [GTK2/3]
Icons: Sardi-Arc [GTK2/3]
Terminal: termite
Terminal Font: Monospace 12
CPU: AMD A9-9425 RADEON R5 2C+3G (2)
GPU: AMD ATI Radeon R2/R3/R4/R5 Grap

cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel

Short version of aplay:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: Generic Analog [Generic Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

Long version of aplay:
aplay -lL
null
Discard all samples (playback) or generate zero samples (capture)
jack
JACK Audio Connection Kit
pulse
PulseAudio Sound Server
sysdefault:CARD=Generic
HD-Audio Generic, Generic Analog
Default Audio Device
usbstream:CARD=Generic
HD-Audio Generic
USB Stream Output
usbstream:CARD=HDMI
HDA ATI HDMI
USB Stream Output
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: Generic Analog [Generic Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0


lspci listing:
lspci -knn|grep -iA2 audio
00:01.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:15b3]
Subsystem: Lenovo Device [17aa:380b]
Kernel driver in use: snd_hda_intel
--
00:09.0 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Carrizo Audio Dummy Host Bridge [1022:157d]
00:09.2 Audio device [0403]: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 60h-6fh) Audio Controller [1022:157a]
Subsystem: Lenovo Family 15h (Models 60h-6fh) Audio Controller [17aa:3811]
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel


ls -l /dev/snd
total 0
drwxr-xr-x 2 root root 80 27 set 23.12 by-path
crw-rw----+ 1 root audio 116, 8 27 set 23.12 controlC0
crw-rw----+ 1 root audio 116, 4 27 set 23.12 controlC1
crw-rw----+ 1 root audio 116, 7 27 set 23.12 hwC0D0
crw-rw----+ 1 root audio 116, 3 27 set 23.12 hwC1D0
crw-rw----+ 1 root audio 116, 6 27 set 23.12 pcmC0D0c
crw-rw----+ 1 root audio 116, 5 27 set 23.12 pcmC0D0p
crw-rw----+ 1 root audio 116, 2 27 set 23.12 pcmC1D3p
crw-rw----+ 1 root audio 116, 1 27 set 23.12 seq
crw-rw----+ 1 root audio 116, 33 27 set 23.12 timer


codecs listing:
lsmod | grep '^snd' | column -t
snd_hda_codec_generic 94208 1
snd_hda_codec_hdmi 69632 1
snd_hda_intel 53248 0
snd_hda_codec 159744 3 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel
snd_hda_core 102400 4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_hwdep 20480 1 snd_hda_codec
snd_pcm 135168 4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer 40960 1 snd_pcm
snd 110592 7 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_pcm


I am opened to any solutions because I really what to stick up with ArcoLinux instead of being forced to use Windows.

Update: managed to have sound, but with no real control over volume. I have used this guide on how to install JACK - the new sound server https://forum.manjaro.org/t/how-to-repl ... nd/2086/15
But using Cadence, as advised in the guide, gives me no control over volume. Can't bring up or down the volume.
Still opened to any solutions.


Post Reply

Return to “Kernel & Hardware”