ArcoLinux -D -B 19.5 iso's have been released

[OPEN] Installing linux-lts (4.19.66-1) breaks dependency required by zfs-linux-lts"

First check the forums - Do not know where to put it then put it here
Post Reply
rpallen
recruit crewman
Posts: 2
Joined: Tue Aug 13, 2019 8:20 pm
Brazil
[OPEN] Installing linux-lts (4.19.66-1) breaks dependency required by zfs-linux-lts"

Post by rpallen » Tue Aug 13, 2019 8:25 pm

Several days ago when I tried to update my arcolinux system I got a message something like (My system is in Portuguese, so the following is my translation.) "It wasn't possible to satisfy the dependencies. Installing linux-lts (4.19.66-1) breaks the dependency 'linux-lts=4.19.61-1' required by zfs-linux-lts"

In the past there have been times when I unsuccessfully tried to update/upgrade an Arch based system. In those previous cases, I tried repeatedly and always after a few days, the update/upgrade would complete. But that isn't happening this time.

When this first happened, I could do a partial upgrade by removing the 2 linux-lts items from the update. But that doesn't work any more and I'm now up to 43 updates available.

Note: I've tried using both the graphical update tool and the CLI (

Code: Select all

sudo pacman -Syy && pacman -Suy
).

What do I need to do to complete the upgrade?

rpallen
recruit crewman
Posts: 2
Joined: Tue Aug 13, 2019 8:20 pm
Brazil
Re: Installing linux-lts (4.19.66-1) breaks dependency required by zfs-linux-lts"

Post by rpallen » Wed Aug 14, 2019 12:57 pm

Followup to my post. I see at https://aur.archlinux.org/packages/zfs-linux-lts/ that the current version of zfs-linux-lts is 0.8.1_4.19.66.1-1 which has 4 dependencies of:

Code: Select all

    kmod (kmod-git)
    zfs-utils=0.8.1 (zfs-utils-git)
    linux-lts=4.19.66-1
    linux-lts-headers=4.19.66-1 (make)
So the current version's dependency isn't linux-lts 4.19.61-1. So why is my system reporting that the update fails to to an old dependency, not the current one? Or isn't/hasn't my system upgraded zfs-lts to the current version? How can I see which version is installed?

User avatar
erikdubois
Captain
Posts: 2346
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: Installing linux-lts (4.19.66-1) breaks dependency required by zfs-linux-lts"

Post by erikdubois » Wed Aug 14, 2019 8:12 pm

I guess you need to install the version 4.19.66-1 for both of them

Code: Select all

sudo pacman -S linux-lts linux-lts-headers
See that version is installed - change mirrors if it is not.

Then you can install zfs-linux-lts.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

User avatar
erikdubois
Captain
Posts: 2346
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Installing linux-lts (4.19.66-1) breaks dependency required by zfs-linux-lts"

Post by erikdubois » Wed Aug 14, 2019 8:15 pm

if in trouble I would delete the zfs-linux-lts and go back to linux-lts or even linux and then install zfs-linux-lts
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.


Post Reply

Return to “General Questions”