the ArcoLinux team wish you a happy new year 2020

[SOLVED] Nvidia Driver Update

Post Reply
User avatar
MicroCode
Crewman
Posts: 23
Joined: Mon Jan 08, 2018 9:32 am
Croatia
[SOLVED] Nvidia Driver Update

Post by MicroCode » Sat Dec 14, 2019 2:53 pm

After updating the Nvidia driver, the computer does not recognize the new driver

before: nvidia 440.36 is works on my PC
after update: nvidia 440.44-1 does not work

Terminal:

Code: Select all

[user@games ~]$ update nvidia-lts nvidia-utils nvidia settings
I tried to fix:

Code: Select all

CTRL + ALT + F2
[user@games ~]$ update
[user@games ~]$ sr
it didn't help, I had to uninstall it

Code: Select all

[user@games ~]$ sudo pacman -R nvidia-lts nvidia-utils nvidia-settings
Restart and work, but with

inxi -b

Code: Select all

System:
  Host: games Kernel: 4.19.88-1-lts x86_64 bits: 64 Desktop: Xfce 4.14.1 
  Distro: ArcoLinux v19.12.15 
Machine:
  Type: Desktop Mobo: ASUSTeK model: H170M-E D3 v: Rev X.0x 
  serial: <root required> UEFI [Legacy]: American Megatrends v: 0503 
  date: 08/07/2015 
CPU:
  Topology: Dual Core model: Intel Core i3-6100 bits: 64 type: MT MCP 
  L2 cache: 3072 KiB 
  Speed: 3543 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
Graphics:
  Device-1: NVIDIA GK104 [GeForce GTX 770] driver: nouveau v: kernel 
  Display: x11 server: X.Org 1.20.6 driver: nouveau 
  unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: NVE4 v: 4.3 Mesa 19.3.0 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio 
  driver: snd_hda_intel 
  Device-2: NVIDIA GK104 HDMI Audio driver: snd_hda_intel 
  Device-3: C-Media CM106 Like Sound Device type: USB 
  driver: hid-generic,snd-usb-audio,usbhid 
  Device-4: Texas Instruments PCM2902 Audio Codec type: USB 
  driver: hid-generic,snd-usb-audio,usbhid 
  Sound Server: ALSA v: k4.19.88-1-lts 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: 30:5a:3a:e4:22:40 
Drives:
  Local Storage: total: 1.64 TiB used: 23.77 GiB (1.4%) 
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB 
  ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-22RKKA0 
  size: 931.51 GiB 
  ID-3: /dev/sdc type: USB vendor: Western Digital model: WD3200BEVT-00A0RT0 
  size: 298.09 GiB 
Partition:
  ID-1: / size: 148.61 GiB used: 23.77 GiB (16.0%) fs: ext4 dev: /dev/sda6 
  ID-2: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 33.0 C mobo: N/A gpu: nouveau temp: 29 C 
  Fan Speeds (RPM): cpu: 0 gpu: nouveau fan: 960 
Info:
  Processes: 187 Uptime: 22m Memory: 7.71 GiB used: 1.40 GiB (18.1%) 
  Shell: termite inxi: 3.0.37

User avatar
MicroCode
Crewman
Posts: 23
Joined: Mon Jan 08, 2018 9:32 am
Croatia
[SOLVED] Re: Nvidia Driver Update

Post by MicroCode » Sun Dec 15, 2019 2:32 pm

Hi,
Today I repeated the new installation of nvidia drivers and all okay WORK :)

I re-installed the package; nvidia nvidia-lts nvidia-utils nvidia-settings

Code: Select all

[user @ games ~] $ sudo pacman -S nvidia nvidia-lts nvidia-utils nvidia-settings
[user @ games ~] $ sr
If the administrator forum thinks this topic is unnecessary please delete it!

[SOLVED]

User avatar
erikdubois
Captain
Posts: 2792
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [SOLVED] Nvidia Driver Update

Post by erikdubois » Mon Dec 16, 2019 7:00 am

IF you install linux kernel

Code: Select all

sudo pacman -S nvidia nvidia-settings nvidia-utils

IF you install linux-lts kernel

Code: Select all

sudo pacman -S nvidia-lts nvidia-settings nvidia-utils
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.


Post Reply

Return to “Graphical Drivers (Nvidia,...)”