ArcoLinux -D -B 19.11 has been released

[SOLVED] Unsupported Resolution while using Nvidia proprietary drivers and forcefullcompositionpipeline

Post Reply
BeNuTzErNaMe
recruit crewman
Posts: 2
Joined: Sun Oct 27, 2019 9:33 am
Germany
[SOLVED] Unsupported Resolution while using Nvidia proprietary drivers and forcefullcompositionpipeline

Post by BeNuTzErNaMe » Sun Oct 27, 2019 9:57 am

Hey forums, i hope i'm not posting this in the wrong category...
Yesterday, I installed ArcoLinuxB with Openbox. On the first boot I had to use boot argument "nouveau.modeset=0" to be able to get onto a terminal and install the proprietary drivers. From then, it worked like a charm aside from screen tearing. I was able to fix it by enabling "Force Full Composition Pipeline" in nvidia-settings. But as I didn't want to do this after every login, I exported the configuration onto my desktop and created a file named "/etc/X11/xorg.conf.d/10-monitor.conf". Then I copied the sections "Screen", "Device" and "Monitor" from the exported over to the new file. That seems to have worked, "Force Full Composition Pipeline" is now enabled as soon as I log in. But sadly, there is a sideeffect to it. As soon as I log out of openbox (via "Exit Openbox" -> "Log out"), there's like a 30% chance, that the resolution (or the refresh timing) is unsupported (if it's not the fault of my monitor). I also wanted to mention that this only happens when I log out, never if I boot up or kill X by "CTRL + ALT + BACKSPACE".

My configurations:
(/etc/X11/xorg.conf.d/00-keyboard.conf)

Code: Select all

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "de"
        Option "XkbModel" "pc105"
EndSection
(/etc/X11/xorg.conf.d/99-killX.conf)

Code: Select all

Section "ServerFlags"
   Option "DontZap" "false"
EndSection

Section "InputClass"
   Identifier      "Keyboard Defaults"
   MatchIsKeyboard   "yes"
   Option         "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
(/etc/X11/xorg.conf.d/10-monitor.conf)

Code: Select all

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 435.21

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "metamodes" "1920x1080_60 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


The exported nvidia-settings file:

Code: Select all

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 435.21

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2311H"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 750 Ti"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "1920x1080_60 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I would be happy if somebody could give me a hint.
Regards

User avatar
erikdubois
Captain
Posts: 2628
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Unsupported Resolution while using Nvidia proprietary drivers and forcefullcompositionpipeline

Post by erikdubois » Sun Oct 27, 2019 11:31 am

If someone can pitch in please
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

xeoncpu
Crewman
Posts: 74
Joined: Fri Nov 10, 2017 8:29 am
Location: Hungary
Hungary
Re: [OPEN] Unsupported Resolution while using Nvidia proprietary drivers and forcefullcompositionpipeline

Post by xeoncpu » Sun Oct 27, 2019 7:52 pm

Hi just simple add this line to openbox autostart file!

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }" &

save and reboot.
and use xrandr or arandr for proper resolution.

BeNuTzErNaMe
recruit crewman
Posts: 2
Joined: Sun Oct 27, 2019 9:33 am
Germany
Re: [OPEN] Unsupported Resolution while using Nvidia proprietary drivers and forcefullcompositionpipeline

Post by BeNuTzErNaMe » Tue Oct 29, 2019 11:04 am

xeoncpu wrote:
Sun Oct 27, 2019 7:52 pm
Hi just simple add this line to openbox autostart file!

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }" &

save and reboot.
and use xrandr or arandr for proper resolution.
After commenting out the metamode-line in the xorg-monitor-config, this worked! Thank you!

User avatar
erikdubois
Captain
Posts: 2628
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [SOLVED] Unsupported Resolution while using Nvidia proprietary drivers and forcefullcompositionpipeline

Post by erikdubois » Tue Oct 29, 2019 11:33 am

Thanks for the assist
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.


Post Reply

Return to “Graphical Drivers (Nvidia,...)”