ArcoLinux -D -B 19.11 has been released

[OPEN] Bad video playing performances with nvidia (UPDATED)

Post Reply
dbl.bzh
Crewman
Posts: 7
Joined: Tue Jun 25, 2019 9:47 pm
France
[OPEN] Bad video playing performances with nvidia (UPDATED)

Post by dbl.bzh » Mon Jul 01, 2019 9:59 pm

Hi guys,

I'm new on Arco Linux and I always have problems of fluidity (fps) when playing videos regardless of the source ...

inxi -F return :

Graphics:
Device-1: Intel HD Graphics 530 driver: i915 v: kernel
Device-2: NVIDIA GK106 [GeForce GTX 660] driver: nvidia v: 430.40
Display: x11 server: X.Org 1.20.5 driver: nvidia resolution: 1360x768~60Hz
OpenGL: renderer: GeForce GTX 660/PCIe/SSE2 v: 4.6.0 NVIDIA 430.40

I've tried on a fresh install and with "nouveau" driver but, it's the same.
I tried a lot of settings provided in the wiki but nothing changes it's always the same ...
I think perhaps to force my system to use Intel integrated chipset for video playing only but i don't know how to do that :?

I really do not know what else to do to solve this problem, so if someone can help me it would be really nice.
Thank you in advance :)
Last edited by dbl.bzh on Thu Aug 08, 2019 3:01 pm, edited 4 times in total.

User avatar
erikdubois
Captain
Posts: 2672
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Bad performances with nvidia / Tearing on web browser scrolling

Post by erikdubois » Mon Jul 01, 2019 10:54 pm

I have no screen tearing on my Nvidia card but I do not use nvidia drivers.

Looking at this link did not help?

https://wiki.archlinux.org/index.php/NV ... en_tearing
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

dbl.bzh
Crewman
Posts: 7
Joined: Tue Jun 25, 2019 9:47 pm
France
Re: [OPEN] Bad performances with nvidia / Tearing on web browser scrolling

Post by dbl.bzh » Mon Jul 08, 2019 11:10 am

Hi Erik,

I'm sorry but i'm trying to switch to nouveau driver for try if i've the same bad performances issues.

Can you tell me how can i switch to nouveau driver and disable nvidia proprietary driver plz ?

Thx a lot

User avatar
erikdubois
Captain
Posts: 2672
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:
Belgium
Re: [OPEN] Bad performances with nvidia / Tearing on web browser scrolling

Post by erikdubois » Mon Jul 08, 2019 12:12 pm

Uninstall the nvidia driver and you will fall back to the nouveau.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

eesau
Crewman
Posts: 33
Joined: Mon Jan 21, 2019 10:04 am
Finland
Re: [OPEN] Bad performances with nvidia / Tearing on web browser scrolling

Post by eesau » Wed Jul 10, 2019 5:29 pm

dbl.bzh wrote:
Mon Jul 08, 2019 11:10 am
Hi Erik,

I'm sorry but i'm trying to switch to nouveau driver for try if i've the same bad performances issues.

Can you tell me how can i switch to nouveau driver and disable nvidia proprietary driver plz ?

Thx a lot
If you want to stick with Nvidia proprietary driver, put this command to auto start and i think you're good. Has worked for me in every Arch install every time.

Code: Select all

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
It's from the link Erik posted.

xeoncpu
Crewman
Posts: 74
Joined: Fri Nov 10, 2017 8:29 am
Location: Hungary
Hungary
Re: [OPEN] Bad performances with nvidia / Tearing on web browser scrolling

Post by xeoncpu » Thu Jul 11, 2019 3:33 pm

Hi!
Put this line to autostart !
nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }" &
if you on nvidia

or do 20-screentearing.conf in /etc/X11/xorg.conf.d/
and put in
Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "Stereo" "0"
Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
SubSection "Display"
Depth 24
EndSubSection
EndSection

dbl.bzh
Crewman
Posts: 7
Joined: Tue Jun 25, 2019 9:47 pm
France
Re: [OPEN] Bad performances with nvidia

Post by dbl.bzh » Thu Aug 08, 2019 2:26 pm

Hi !
Thanks a lot for your answers.
Indeed the tearing problem is now regulated with the addition of the activation of the pipeline composition.
Unfortunately the performance when playing videos regardless of the source is still present.
Normally my graphics card should be enough to play videos in good conditions.
I do not really understand why I have these problems.

I did a search directly on the nvidia site by following the videos of the community on the subject and he tells me that I can use the last driver for my graphics card.
Image
Image

If you have an idea to give to me it would be very great :)
thank you in advance

eesau
Crewman
Posts: 33
Joined: Mon Jan 21, 2019 10:04 am
Finland
Re: [OPEN] Bad video playing performances with nvidia (UPDATED)

Post by eesau » Sat Aug 10, 2019 2:42 pm

Do you mean playing local videos or in browser, like Youtube etc? What kind of videos are they if they're local? Which browser do you use?

In what way is the video playback bad?

dbl.bzh
Crewman
Posts: 7
Joined: Tue Jun 25, 2019 9:47 pm
France
Re: [OPEN] Bad video playing performances with nvidia (UPDATED)

Post by dbl.bzh » Tue Aug 13, 2019 3:01 pm

Hi eesau,

The problem is the same with all sources, like VLC, SMPlayer, MPV, Firefox, Chrome...

When i'm playing a video, i've some little fps drop and the video seems to be hashed.

Today an update of compton has been done on my system and after reboot compositor is down, no one transparency/shadow effect is applied...

But video playing correctly now.

So I think the problem comes from compton ... But where I have no idea ...

eesau
Crewman
Posts: 33
Joined: Mon Jan 21, 2019 10:04 am
Finland
Re: [OPEN] Bad video playing performances with nvidia (UPDATED)

Post by eesau » Tue Aug 13, 2019 6:56 pm

Sounds odd to me, haven't had such problems ever in any system. I've had screen tearing and other glitches in browser, but never with local video files.

But if it's ok with Compton disabled, try to live without it. Not ideal, but quite ok i guess. I'd take fluid system over effects any day.


Post Reply

Return to “Graphical Drivers (Nvidia,...)”