[SOLVED] Cant change font hinting

First check the forums - Do not know where to put it then put it here
Post Reply
ajayP89
Crewman
Posts: 3
Joined: Thu Nov 19, 2020 12:05 pm

[SOLVED] Cant change font hinting

Post by ajayP89 »

I have installed arcolinuxB spectrwm. Everything runs smoothly but I'm facing issue where changing font hinting from full to slight in lxappearance has no effect. On reopening it again, hinting goes back to full. I have edited fontconfig file in ~/.config and also created local.conf in /etc/fonts/ to change hinting to hintslight but lxappearance still shows hinting as full

User avatar
erikdubois
Captain
Posts: 3547
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] Cant change font hinting

Post by erikdubois »

Lxappearance is an application for LXDM or LXQT.

Some elements will work others will not.

The question might also be. Is there something else that is changing settings? Combo with other Desktops?

When on tiling window managers we often go directly to the file and change it there.
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

ajayP89
Crewman
Posts: 3
Joined: Thu Nov 19, 2020 12:05 pm

Re: [Solved] Cant change font hinting

Post by ajayP89 »

ok..so it seems lxappearance is reporting full when actually font hinting is slight. It is working fine now.

User avatar
erikdubois
Captain
Posts: 3547
Joined: Tue Nov 07, 2017 3:45 pm
Location: Belgium
Contact:

Re: [OPEN] Cant change font hinting

Post by erikdubois »

great
Learn, have fun and enjoy.
But first use the power of the Arch Wiki
use the tutorials on https://www.youtube.com/erikdubois
then use the power of google
then use the power of our moderators.

ajayP89
Crewman
Posts: 3
Joined: Thu Nov 19, 2020 12:05 pm

Re: [SOLVED] Cant change font hinting

Post by ajayP89 »

apparently there is a known issue with gtk apps & lxappearance. Had to edit ~/.gtkrc-2.0 and ~/.config/gtk-3.0/settings.ini & changing hintstyle there & also adding the follwong to .Xresources:

Code: Select all

Xft.autohint: 0
Xft.antialias: 1
Xft.hinting: true
Xft.hintstyle: hintslight
Xft.dpi: 96
Xft.rgba: rgb
Xft.lcdfilter: lcddefault

Post Reply

Return to “General Questions”